summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-10 00:44:43 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-10 09:06:33 +0100
commit2d735ad7438641f75438997fcd22d3ce7b9bf8ef (patch)
tree65ca8049df9b3ce225fe55dea89063efe777fcdc
parentdev-python/boto3: Bump to 1.17.5 (diff)
downloadgentoo-2d735ad7438641f75438997fcd22d3ce7b9bf8ef.tar.gz
gentoo-2d735ad7438641f75438997fcd22d3ce7b9bf8ef.tar.bz2
gentoo-2d735ad7438641f75438997fcd22d3ce7b9bf8ef.zip
dev-python/soupsieve: Bump to 2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/soupsieve/Manifest1
-rw-r--r--dev-python/soupsieve/soupsieve-2.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/soupsieve/Manifest b/dev-python/soupsieve/Manifest
index b85ec7128837..64ebe4d5ca41 100644
--- a/dev-python/soupsieve/Manifest
+++ b/dev-python/soupsieve/Manifest
@@ -1 +1,2 @@
DIST soupsieve-2.1.0.tar.gz 98150 BLAKE2B 37f6ef00f42d164ef57be88135e8a942166f53a39ed5643d6ae0468916a66be04c79e4e70da6ad38f8adf6fac41cb8bccb7edcfabd7e1a07083ab8a043d5203a SHA512 19cd4ee596d189a001bbaf9f047e6c9eff569e2149ef5424bfe55c9b4325d856c957de87d55510335f748aab322dbb847b06b48931fbdeadbcc3790259c69eb1
+DIST soupsieve-2.2.tar.gz 99261 BLAKE2B 637bed198a62a7f92f6b3c022dcb9a579c15a3dcb1e3581b5a18b9ff804c2075c976c3478f86d2400841c177f3160dc05da41991ca56731c91e6db5b95262671 SHA512 26402c831c19c9b133442dd8ea31363e1eadc3cafe172b933cdbc746df6dc9961e930d4fbe8399b847848bf3fcd5893d2449e912ed0cdf8766468997acf5ee87
diff --git a/dev-python/soupsieve/soupsieve-2.2.ebuild b/dev-python/soupsieve/soupsieve-2.2.ebuild
new file mode 100644
index 000000000000..ff825943ef73
--- /dev/null
+++ b/dev-python/soupsieve/soupsieve-2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="https://github.com/facelessuser/soupsieve/
+ https://pypi.org/project/soupsieve/"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT+=" !test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest