summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 21:40:34 +0100
committerSam James <sam@gentoo.org>2021-04-19 21:54:05 +0100
commit5394e99bedc11545e2afe5a8d829df2304763a0c (patch)
tree71841540225129af21719ca2a5d07f2bb66ead28
parentapp-laptop/tpb: port to EAPI 7 (diff)
downloadgentoo-5394e99bedc11545e2afe5a8d829df2304763a0c.tar.gz
gentoo-5394e99bedc11545e2afe5a8d829df2304763a0c.tar.bz2
gentoo-5394e99bedc11545e2afe5a8d829df2304763a0c.zip
app-text/blahtexml: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/blahtexml/blahtexml-0.9.ebuild20
-rw-r--r--app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch8
2 files changed, 18 insertions, 10 deletions
diff --git a/app-text/blahtexml/blahtexml-0.9.ebuild b/app-text/blahtexml/blahtexml-0.9.ebuild
index 5e893a55f267..f470b6197643 100644
--- a/app-text/blahtexml/blahtexml-0.9.ebuild
+++ b/app-text/blahtexml/blahtexml-0.9.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="TeX-to-MathML converter"
HOMEPAGE="http://gva.noekeon.org/blahtexml"
@@ -15,16 +15,24 @@ KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 x86"
IUSE="doc"
RDEPEND="dev-libs/xerces-c"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
doc? (
app-text/texlive-core
dev-libs/libxslt
- dev-tex/latex2html )"
+ dev-tex/latex2html
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+)
src_prepare() {
- tc-export CC CXX
- epatch "${FILESDIR}"/${P}-{Makefile,gcc-4.7}.patch
+ default
+
+ tc-export CC CXX PKG_CONFIG
}
src_compile() {
diff --git a/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch b/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch
index c570e1de679b..9b3e53047fb3 100644
--- a/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch
+++ b/app-text/blahtexml/files/blahtexml-0.9-gcc-4.7.patch
@@ -2,8 +2,8 @@ Description: Fix FTBFS with gcc 4.7 by fixing missing <unistd.h> includes.
Author: Cyril Brulebois <kibi@debian.org>
Bug-Debian: http://bugs.debian.org/667116
---- blahtexml-0.9.orig/Source/main.cpp
-+++ blahtexml-0.9/Source/main.cpp
+--- a/Source/main.cpp
++++ b/Source/main.cpp
@@ -24,6 +24,7 @@ THIS SOFTWARE IS PROVIDED BY THE COPYRIG
#include <stdlib.h>
#include <sstream>
@@ -12,8 +12,8 @@ Bug-Debian: http://bugs.debian.org/667116
using namespace std;
using namespace blahtex;
---- blahtexml-0.9.orig/Source/mainPng.cpp
-+++ blahtexml-0.9/Source/mainPng.cpp
+--- a/Source/mainPng.cpp
++++ b/Source/mainPng.cpp
@@ -27,6 +27,7 @@ THIS SOFTWARE IS PROVIDED BY THE COPYRIG
#include <stdio.h>
#include <stdlib.h>