summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-21 06:29:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-21 06:40:22 +0100
commit57ea6131357e68e00a6d77665f2c5b56f3b54d33 (patch)
treeeb6f88a0f43978d544b6786762a0f390aa7e3db1
parentdev-python/cysignals: Bump to 1.12.0 (diff)
downloadgentoo-57ea6131357e68e00a6d77665f2c5b56f3b54d33.tar.gz
gentoo-57ea6131357e68e00a6d77665f2c5b56f3b54d33.tar.bz2
gentoo-57ea6131357e68e00a6d77665f2c5b56f3b54d33.zip
dev-python/google-api-python-client: Bump to 2.154.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.154.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index bfc7df4fda11..10c7c63f71a4 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google_api_python_client-2.151.0.tar.gz 12030480 BLAKE2B afbe2cb25e789aaa1aa5cf94e0b2a8e910cb097a885d6dc479af27e7836ac96a2a3db7b54b3fe5e060bdd4c0bdfa86dab3f0cab2e0ea176a6802d455ec7eda77 SHA512 3a8f55f457106779798e0bdf544c9bb9482967dcf0329a9a85f390a4acf8b9946ee56e43af798966c0958ae934426081bbf29cbb344071f2589b84937e85ed37
DIST google_api_python_client-2.152.0.tar.gz 12046554 BLAKE2B 019bf46e4c876cf77028e1c8d71983a1b37abe95001c713d3b9a5063781c4fb329ecd4137c1ce706a5266b8445f757261c31964b5a9defe0433e94573453091b SHA512 4dc7e551c4defa6a6607a5838e2f282a5a669f0bc6d8bfc676d90fb4394a898667e023c042ffab56c9ea9638256a6671d095d3a5b8c5af1e49f60d1b6d416790
DIST google_api_python_client-2.153.0.tar.gz 12059322 BLAKE2B dec9affc093262984d9f050dbc55a746d9747c6069b54a85edf14ad037b732ba614e4f0c3dfd0ef678f79aec598625ccd5ce80e942870999f5f0c147337e261a SHA512 c4066807e2e6096b90f6cbe51c20919429abd7c9b25fcefbdd849e290335d926e2b190ad3e61531681589176bbbb72c77f53858687bfee040b1dda36f92ffef3
+DIST google_api_python_client-2.154.0.tar.gz 12070143 BLAKE2B 91b2838116246e04fc93a155fb27792a2efa6e258eeddf29989c62229db7975b389435efeb6342d069358797539c57ea630c7bf7da64a0cdef7ceb4801586a85 SHA512 9728f4cda59919ddec28876f27b6e7716d96c9ba08088f064aa1ac0e0a4ccd1d7ad66e592ac8e2429f04520b64d8228fd3d358f7ae7d157048c9719fcb7b8cd3
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.154.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.154.0.ebuild
new file mode 100644
index 000000000000..58a0eb467bad
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.154.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}