summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-29 06:03:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-29 06:03:40 +0200
commit6d54e7229efda3307b4891e0e4c8a51868dfe626 (patch)
tree33df5b9b8c8bb523337b680376c2a5800f357156
parentdev-python/httpbin: Bump to 0.10.1 (diff)
downloadgentoo-6d54e7229efda3307b4891e0e4c8a51868dfe626.tar.gz
gentoo-6d54e7229efda3307b4891e0e4c8a51868dfe626.tar.bz2
gentoo-6d54e7229efda3307b4891e0e4c8a51868dfe626.zip
dev-python/pyspnego: Bump to 0.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyspnego/Manifest1
-rw-r--r--dev-python/pyspnego/pyspnego-0.9.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index 174fde666dce..a56c67118a3e 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1 +1,2 @@
DIST pyspnego-0.9.1.tar.gz 233824 BLAKE2B c36d2ee697ed9dcb7a3c7d3a3ec2bc58b88ac6ba5a020c852b4ba7d0a01d3dd4a3801d91a9456f3f4710684df16a3a4c7d449cfa58e141ae5085bef0f0fe6f21 SHA512 6c516cae43bff523ec19b6ef52e7691a688bada027a183b98e0121bdd4f44f887a5fa87f3ab173dff1e18d84a7886a2a04de80dbd6873cc1dafb1d7369a9d932
+DIST pyspnego-0.9.2.tar.gz 233819 BLAKE2B e4fc4b8cd760210c2e4dd188a651725fa6579fe429ca227e8a5cc1f46111e3e8e6cb07bc4256f60560d86bcd0a2b2e621efbd0dc193d3f67f66a1fdb79ef8f9e SHA512 6775efa12b1f93addf9257145d020e5fcb5139edf8ffcbdca03cd55de7ee992b47af5278206de85e50a824abbf0a037a50dc7e47ca5b6f79b2f4e854d926a8f3
diff --git a/dev-python/pyspnego/pyspnego-0.9.2.ebuild b/dev-python/pyspnego/pyspnego-0.9.2.ebuild
new file mode 100644
index 000000000000..814c28e01ada
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.9.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}