summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-10-18 11:46:15 -0400
committerSam James <sam@gentoo.org>2023-10-18 16:55:30 +0100
commit86be11692e59d41b3f6efbe86dfbf38202b1c9ad (patch)
treebfa19fd8e3abdf920fe29e8de0a70183182cd8bd
parentdev-python/qscintilla-python: Stabilize 2.14.1 x86, #915930 (diff)
downloadgentoo-86be11692e59d41b3f6efbe86dfbf38202b1c9ad.tar.gz
gentoo-86be11692e59d41b3f6efbe86dfbf38202b1c9ad.tar.bz2
gentoo-86be11692e59d41b3f6efbe86dfbf38202b1c9ad.zip
dev-util/ninja: add pkg_postinst workaround for ninja symlink
This commit adds a workaround in pkg_postinst similar to other packages covered by app-alternatives such as app-arch/tar. If the ninja symlink does not already exist in pkg_postinst, temporarily symlink ninja-reference to ensure there is no breakage between the update and the subsequent merge of app-alternatives/ninja. Signed-off-by: Violet Purcell <vimproved@inventati.org> Closes: https://github.com/gentoo/gentoo/pull/33396 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/ninja/ninja-1.11.1-r3.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-util/ninja/ninja-1.11.1-r3.ebuild b/dev-util/ninja/ninja-1.11.1-r3.ebuild
index 4f8bdfff6267..c4874b6be066 100644
--- a/dev-util/ninja/ninja-1.11.1-r3.ebuild
+++ b/dev-util/ninja/ninja-1.11.1-r3.ebuild
@@ -121,6 +121,9 @@ src_install() {
pkg_postinst() {
use emacs && elisp-site-regen
+ if ! [[ -e "${EROOT}/usr/bin/ninja" ]]; then
+ ln -s ninja-reference "${EROOT}/usr/bin/ninja" || die
+ fi
}
pkg_postrm() {