summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-18 04:23:41 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-18 04:37:02 +0200
commit96bf5de01a9cd6bc54b00602db356057439561b2 (patch)
tree9e252eebaf45d84dfbe068435d4a4cec154ce15d
parentdev-python/rarfile: Bump to 4.1 (diff)
downloadgentoo-96bf5de01a9cd6bc54b00602db356057439561b2.tar.gz
gentoo-96bf5de01a9cd6bc54b00602db356057439561b2.tar.bz2
gentoo-96bf5de01a9cd6bc54b00602db356057439561b2.zip
dev-python/pytest-codeblocks: Bump to 0.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytest-codeblocks/Manifest1
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/Manifest b/dev-python/pytest-codeblocks/Manifest
index 23156e782aff..a7c6ed753267 100644
--- a/dev-python/pytest-codeblocks/Manifest
+++ b/dev-python/pytest-codeblocks/Manifest
@@ -1 +1,2 @@
DIST pytest-codeblocks-0.16.1.gh.tar.gz 8900 BLAKE2B 1e884f445975c4c685e763560a8bb5516bd7213b09a8c967948347e455816766dccfd0984fb5746949f90afdf00e0fe21a52f41be65933532d8763ed6ea716a1 SHA512 4c3d91488550373832c8dd45b39873ae3810b423147b3b9524afc8e205605324092b4462b62acf2e34e70b5456795834cae511d9c9a06e08288a46cdb38b1778
+DIST pytest-codeblocks-0.17.0.gh.tar.gz 9104 BLAKE2B 50f6d7cdf0c2d355c91a1a518622f65c4520a4e655d9c6aae64b0ea7697cf2605f37cf070fc9b7c60c2aef655b5a9adacd5acf4dbfbca2ccb8224316733dc269 SHA512 20044f10e997fbe15a8389aebdad324c2b102a11287315c8c85042f5497f51723c030b918f0cd923beb9f0c5b33a41673426a8c550814e1bd8b9b5476dd0dbf5
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
new file mode 100644
index 000000000000..96506654b3f7
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.17.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="
+ https://github.com/nschloe/pytest-codeblocks/
+ https://pypi.org/project/pytest_codeblocks/
+"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p pytester
+}