summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuang Rui <vowstar@gmail.com>2023-03-28 20:47:50 +0800
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-11 10:43:07 +0200
commitbf274374087447c2bec8073170f20244eae14dc5 (patch)
tree976551920b9cdb46638f9f886443c7900457acf1
parentapp-text/xml2rfc: add 3.18.0 (diff)
downloadgentoo-bf274374087447c2bec8073170f20244eae14dc5.tar.gz
gentoo-bf274374087447c2bec8073170f20244eae14dc5.tar.bz2
gentoo-bf274374087447c2bec8073170f20244eae14dc5.zip
dev-libs/cudnn: add 8.8.0.121
Closes: https://bugs.gentoo.org/895134 Signed-off-by: Huang Rui <vowstar@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30377 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-libs/cudnn/Manifest1
-rw-r--r--dev-libs/cudnn/cudnn-8.8.0.121.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/cudnn/Manifest b/dev-libs/cudnn/Manifest
index e40698740823..9c34802ba57a 100644
--- a/dev-libs/cudnn/Manifest
+++ b/dev-libs/cudnn/Manifest
@@ -1 +1,2 @@
DIST cudnn-linux-x86_64-8.6.0.163_cuda11-archive.tar.xz 864470696 BLAKE2B e842f5861653f2bc8509cc654e5c40436556786610fbc4ab40781cd8246d5bc94e3e3fae0b0933c947941dc0b6eacbd44d6a54702566e5aefcff56df3f884149 SHA512 15d86b8884bf7b48b4aa1022ea26f0965dd50a9911ca1e6fb89e5266181e662547ba077b2e2e9f19bd135aef9d21fb0a3348b97c7fac9059bb241657046d6d60
+DIST cudnn-linux-x86_64-8.8.0.121_cuda12-archive.tar.xz 871089052 BLAKE2B 48f4142d7fea4192e4a910807fa7344c75372aa0d4a68e020416de960eb4b344262551e374b26cdd323751c3c75a000c63a326ece6f801a6ddfbfe06fe51ee6c SHA512 ffdbc1ca4fb03c6906b6896763790ca288aba098e50ed2fbf33a2b994a09386bc6fb5ec9a3a49a82be494331f43c85e22fa406575c4fddb30246f32ee85660e7
diff --git a/dev-libs/cudnn/cudnn-8.8.0.121.ebuild b/dev-libs/cudnn/cudnn-8.8.0.121.ebuild
new file mode 100644
index 000000000000..8cd14f1c16a4
--- /dev/null
+++ b/dev-libs/cudnn/cudnn-8.8.0.121.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+BASE_V="$(ver_cut 0-3)"
+# supports 12.x but URL has a specific version number
+CUDA_MA="12"
+CUDA_MI="8"
+CUDA_V="${CUDA_MA}.${CUDA_MI}"
+
+DESCRIPTION="NVIDIA Accelerated Deep Learning on GPU library"
+HOMEPAGE="https://developer.nvidia.com/cudnn"
+SRC_URI="https://developer.download.nvidia.com/compute/cudnn/redist/cudnn/linux-x86_64/cudnn-linux-x86_64-${PV}_cuda${CUDA_MA}-archive.tar.xz"
+S="${WORKDIR}/cudnn-linux-x86_64-${PV}_cuda${CUDA_MA}-archive"
+
+LICENSE="NVIDIA-cuDNN"
+SLOT="0/8"
+KEYWORDS="~amd64 ~amd64-linux"
+RESTRICT="mirror"
+
+RDEPEND="=dev-util/nvidia-cuda-toolkit-12*"
+
+QA_PREBUILT="/opt/cuda/targets/x86_64-linux/lib/*"
+
+src_install() {
+ insinto /opt/cuda/targets/x86_64-linux
+ doins -r include lib
+}