summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-06 07:44:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-18 22:00:17 +0200
commitd2ff2ee4cd5972048073e214c604770446cfbd1b (patch)
tree1062860d012814bd5db8f9b4cdaafc0cb10a63d9
parentsys-cluster/kube-scheduler: add 1.24.5 (diff)
downloadgentoo-d2ff2ee4cd5972048073e214c604770446cfbd1b.tar.gz
gentoo-d2ff2ee4cd5972048073e214c604770446cfbd1b.tar.bz2
gentoo-d2ff2ee4cd5972048073e214c604770446cfbd1b.zip
Rename dev-python/{python-levenshtein → Levenshtein}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-text/paperwork-backend/paperwork-backend-2.1.0.ebuild4
-rw-r--r--app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild2
-rw-r--r--dev-python/Levenshtein/Levenshtein-0.12.2.ebuild (renamed from dev-python/python-levenshtein/python-levenshtein-0.12.2.ebuild)2
-rw-r--r--dev-python/Levenshtein/Manifest (renamed from dev-python/python-levenshtein/Manifest)0
-rw-r--r--dev-python/Levenshtein/metadata.xml (renamed from dev-python/python-levenshtein/metadata.xml)0
-rw-r--r--dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0.ebuild2
-rw-r--r--dev-python/textdistance/textdistance-4.3.0.ebuild2
-rw-r--r--dev-python/textdistance/textdistance-4.4.0.ebuild2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.7.3.ebuild2
-rw-r--r--profiles/updates/3Q-20221
11 files changed, 10 insertions, 9 deletions
diff --git a/app-text/paperwork-backend/paperwork-backend-2.1.0.ebuild b/app-text/paperwork-backend/paperwork-backend-2.1.0.ebuild
index b20acac9dac9..4f0cf6cbd94d 100644
--- a/app-text/paperwork-backend/paperwork-backend-2.1.0.ebuild
+++ b/app-text/paperwork-backend/paperwork-backend-2.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,6 +18,7 @@ IUSE=""
RDEPEND="app-text/poppler[introspection]
dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
dev-python/natsort[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
@@ -25,7 +26,6 @@ RDEPEND="app-text/poppler[introspection]
dev-python/pycountry[${PYTHON_USEDEP}]
dev-python/pyenchant[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-levenshtein[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/whoosh[${PYTHON_USEDEP}]
sci-libs/scikit-learn[${PYTHON_USEDEP}]"
diff --git a/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild b/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild
index 820e83331f39..f5bcf8a9e058 100644
--- a/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild
+++ b/app-text/paperwork-backend/paperwork-backend-2.1.1.ebuild
@@ -18,6 +18,7 @@ IUSE=""
RDEPEND="app-text/poppler[introspection]
dev-python/distro[${PYTHON_USEDEP}]
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
dev-python/natsort[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
@@ -25,7 +26,6 @@ RDEPEND="app-text/poppler[introspection]
dev-python/pycountry[${PYTHON_USEDEP}]
dev-python/pyenchant[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-levenshtein[${PYTHON_USEDEP}]
dev-python/termcolor[${PYTHON_USEDEP}]
dev-python/whoosh[${PYTHON_USEDEP}]
sci-libs/scikit-learn[${PYTHON_USEDEP}]"
diff --git a/dev-python/python-levenshtein/python-levenshtein-0.12.2.ebuild b/dev-python/Levenshtein/Levenshtein-0.12.2.ebuild
index eb68abba9ce0..9a69b15794fa 100644
--- a/dev-python/python-levenshtein/python-levenshtein-0.12.2.ebuild
+++ b/dev-python/Levenshtein/Levenshtein-0.12.2.ebuild
@@ -13,7 +13,7 @@ inherit distutils-r1
DESCRIPTION="Functions for fast computation of Levenshtein distance, and edit operations"
HOMEPAGE="https://pypi.org/project/python-Levenshtein/
https://github.com/ztane/python-Levenshtein/"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
diff --git a/dev-python/python-levenshtein/Manifest b/dev-python/Levenshtein/Manifest
index f40b2e341618..f40b2e341618 100644
--- a/dev-python/python-levenshtein/Manifest
+++ b/dev-python/Levenshtein/Manifest
diff --git a/dev-python/python-levenshtein/metadata.xml b/dev-python/Levenshtein/metadata.xml
index 414d22588236..414d22588236 100644
--- a/dev-python/python-levenshtein/metadata.xml
+++ b/dev-python/Levenshtein/metadata.xml
diff --git a/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0.ebuild b/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0.ebuild
index 4ccd97dca9b5..8cf3de7a61f0 100644
--- a/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0.ebuild
+++ b/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0.ebuild
@@ -15,7 +15,7 @@ KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
LICENSE="GPL-2"
SLOT="0"
-RDEPEND="dev-python/python-levenshtein[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/Levenshtein[${PYTHON_USEDEP}]"
BDEPEND="test? ( dev-python/pycodestyle[${PYTHON_USEDEP}] )"
distutils_enable_tests pytest
diff --git a/dev-python/textdistance/textdistance-4.3.0.ebuild b/dev-python/textdistance/textdistance-4.3.0.ebuild
index b7752b1c5c8d..181a9035a3f4 100644
--- a/dev-python/textdistance/textdistance-4.3.0.ebuild
+++ b/dev-python/textdistance/textdistance-4.3.0.ebuild
@@ -22,8 +22,8 @@ BDEPEND="
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/isort[${PYTHON_USEDEP}]
dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-levenshtein[${PYTHON_USEDEP}]
dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
)"
diff --git a/dev-python/textdistance/textdistance-4.4.0.ebuild b/dev-python/textdistance/textdistance-4.4.0.ebuild
index 6b3f959525b4..427ee9e48841 100644
--- a/dev-python/textdistance/textdistance-4.4.0.ebuild
+++ b/dev-python/textdistance/textdistance-4.4.0.ebuild
@@ -23,8 +23,8 @@ BDEPEND="
dev-python/hypothesis[${PYTHON_USEDEP}]
dev-python/isort[${PYTHON_USEDEP}]
dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-levenshtein[${PYTHON_USEDEP}]
dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
)"
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild
index 7022e482cf3f..97ae988d9918 100644
--- a/dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild
+++ b/dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild
@@ -30,9 +30,9 @@ RDEPEND="
app-text/iso-codes
>=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
>=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
>=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
- >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
>=dev-python/pyparsing-3[${PYTHON_USEDEP}]
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
sys-devel/gettext
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.7.3.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.7.3.ebuild
index 7c5cbdaf61ca..5506bd44030d 100644
--- a/dev-python/translate-toolkit/translate-toolkit-3.7.3.ebuild
+++ b/dev-python/translate-toolkit/translate-toolkit-3.7.3.ebuild
@@ -30,9 +30,9 @@ RDEPEND="
app-text/iso-codes
>=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
>=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
>=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
- >=dev-python/python-levenshtein-0.12.0[${PYTHON_USEDEP}]
>=dev-python/pyparsing-3[${PYTHON_USEDEP}]
dev-python/ruamel-yaml[${PYTHON_USEDEP}]
sys-devel/gettext
diff --git a/profiles/updates/3Q-2022 b/profiles/updates/3Q-2022
index 87339087d27c..5b6de63728a9 100644
--- a/profiles/updates/3Q-2022
+++ b/profiles/updates/3Q-2022
@@ -15,3 +15,4 @@ move net-p2p/go-ipfs net-p2p/kubo
move app-admin/ansible-base app-admin/ansible-core
slotmove =dev-ruby/rack-test-2.0.2 1.0 2
move app-office/gnome-todo app-office/endeavour
+move dev-python/python-levenshtein dev-python/Levenshtein