summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Petrina <jakov.petrina@sartura.hr>2021-10-14 16:38:51 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-19 12:50:24 +0200
commitef32933b0fdabfafa27e5b75840e3ff7e109f6b5 (patch)
tree89de92fe28b4fb95796d6dee5ac5eb67c70ba9d0
parentsys-apps/file: Bump to version 5.41 (diff)
downloadgentoo-ef32933b0fdabfafa27e5b75840e3ff7e109f6b5.tar.gz
gentoo-ef32933b0fdabfafa27e5b75840e3ff7e109f6b5.tar.bz2
gentoo-ef32933b0fdabfafa27e5b75840e3ff7e109f6b5.zip
app-misc/jdupes: initial import
This change introduces the jdupes package which is an improved fork of the original fdupes package. Closes: https://bugs.gentoo.org/637344 Signed-off-by: Jakov Petrina <jakov.petrina@sartura.hr> Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--app-misc/jdupes/Manifest1
-rw-r--r--app-misc/jdupes/jdupes-1.20.0.ebuild37
-rw-r--r--app-misc/jdupes/jdupes-9999.ebuild37
-rw-r--r--app-misc/jdupes/metadata.xml15
4 files changed, 90 insertions, 0 deletions
diff --git a/app-misc/jdupes/Manifest b/app-misc/jdupes/Manifest
new file mode 100644
index 000000000000..d6600033be09
--- /dev/null
+++ b/app-misc/jdupes/Manifest
@@ -0,0 +1 @@
+DIST jdupes-1.20.0.tar.gz 93809 BLAKE2B cce6ca06794ee3af9523e3c86550ff2b49a5f42a13278bd61c99099b4c2cab1a392bc973c44593acb23b7e8f99d4f23518f526244182a0d9d3b4084e80cc1015 SHA512 62bb78a902e77f0c9acce93c7c139fc2aaa5911aa85322a372dd0e6b375ee5c4992e91b821fa3f9eb407820657f57591303c9bc14a9fe453d9a4c5651caf05ff
diff --git a/app-misc/jdupes/jdupes-1.20.0.ebuild b/app-misc/jdupes/jdupes-1.20.0.ebuild
new file mode 100644
index 000000000000..681f1d0f1493
--- /dev/null
+++ b/app-misc/jdupes/jdupes-1.20.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify duplicate files on the filesystem"
+HOMEPAGE="https://github.com/jbruchon/jdupes"
+if [[ "${PV}" == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+# missing test.sh script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/PREFIX/s/=/?=/' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}
diff --git a/app-misc/jdupes/jdupes-9999.ebuild b/app-misc/jdupes/jdupes-9999.ebuild
new file mode 100644
index 000000000000..681f1d0f1493
--- /dev/null
+++ b/app-misc/jdupes/jdupes-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Identify duplicate files on the filesystem"
+HOMEPAGE="https://github.com/jbruchon/jdupes"
+if [[ "${PV}" == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/jbruchon/jdupes.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jbruchon/jdupes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+LICENSE="MIT"
+SLOT="0"
+
+# missing test.sh script
+# https://github.com/jbruchon/jdupes/issues/191
+RESTRICT="test"
+
+src_prepare() {
+ sed -i -e '/PREFIX/s/=/?=/' Makefile || die
+ default
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ einstalldocs
+}
diff --git a/app-misc/jdupes/metadata.xml b/app-misc/jdupes/metadata.xml
new file mode 100644
index 000000000000..8d9826eecd5b
--- /dev/null
+++ b/app-misc/jdupes/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>jakov.petrina@sartura.hr</email>
+ <name>Jakov Petrina</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>jsmolic@gentoo.org</email>
+ <name>Jakov Smolić</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jbruchon/jdupes</remote-id>
+ </upstream>
+</pkgmetadata>