summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-23 04:19:55 +0000
committerSam James <sam@gentoo.org>2021-03-23 04:19:55 +0000
commitdd323a38284c9a324d0316e1136f884bf831ba89 (patch)
tree5a29ff1978aa9f47a2fd42855cbee1c60576b9d2 /app-admin/authbind
parentsys-process/parallel: add 20210322 (diff)
downloadgentoo-dd323a38284c9a324d0316e1136f884bf831ba89.tar.gz
gentoo-dd323a38284c9a324d0316e1136f884bf831ba89.tar.bz2
gentoo-dd323a38284c9a324d0316e1136f884bf831ba89.zip
app-admin/authbind: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin/authbind')
-rw-r--r--app-admin/authbind/authbind-2.1.1.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/app-admin/authbind/authbind-2.1.1.ebuild b/app-admin/authbind/authbind-2.1.1.ebuild
index c7a9890aa7ce..0d4fef683b83 100644
--- a/app-admin/authbind/authbind-2.1.1.ebuild
+++ b/app-admin/authbind/authbind-2.1.1.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils multilib flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Bind sockets to privileged ports without root"
-HOMEPAGE="http://www.chiark.greenend.org.uk/ucgi/~ian/git/authbind.git/"
+HOMEPAGE="https://www.chiark.greenend.org.uk/ucgi/~ian/git/authbind.git/"
SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
-RDEPEND=""
+BDEPEND="virtual/awk"
-src_prepare() {
- epatch "${FILESDIR}/${P}-respect-flags.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${P}-respect-flags.patch"
+)
src_configure() {
+ tc-export CC LD
+
sed -i \
-e "s|^prefix=.*|prefix=/usr|" \
-e "s|^lib_dir=.*|lib_dir=\$(prefix)/$(get_libdir)|" \
@@ -38,7 +38,8 @@ src_install() {
dobin authbind
doman authbind.1 authbind-helper.8
- ln -s libauthbind.so.* libauthbind.so.$(awk -F= '/MAJOR=/ { print $2 }' < Makefile)
+ local major=$(awk -F= '/MAJOR=/ { print $2 }' Makefile || die)
+ ln -s libauthbind.so.* libauthbind.so.${major} || die
dolib.so libauthbind.so*
exeinto /usr/libexec/authbind