summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2017-03-10 17:06:23 +0100
committerPatrick Lauer <patrick@gentoo.org>2017-03-10 17:06:35 +0100
commit82baf775f7213935bcc6ce75edc75fbd48344ee7 (patch)
treebd19bb149a79a128c6f5d14a161be9136ce1c76e /app-admin/lsyncd/lsyncd-2.2.2.ebuild
parentapp-portage/pqlop: Add python3_5 support (diff)
downloadgentoo-82baf775f7213935bcc6ce75edc75fbd48344ee7.tar.gz
gentoo-82baf775f7213935bcc6ce75edc75fbd48344ee7.tar.bz2
gentoo-82baf775f7213935bcc6ce75edc75fbd48344ee7.zip
app-admin/lsyncd: Bump
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'app-admin/lsyncd/lsyncd-2.2.2.ebuild')
-rw-r--r--app-admin/lsyncd/lsyncd-2.2.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/lsyncd/lsyncd-2.2.2.ebuild b/app-admin/lsyncd/lsyncd-2.2.2.ebuild
new file mode 100644
index 000000000000..4e14745a58b4
--- /dev/null
+++ b/app-admin/lsyncd/lsyncd-2.2.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_IN_SOURCE_BUILD="YES_PLEASE_OMG"
+inherit cmake-utils
+
+DESCRIPTION="Live Syncing (Mirror) Daemon"
+HOMEPAGE="https://github.com/axkibe/lsyncd"
+SRC_URI="https://github.com/axkibe/lsyncd/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+
+CDEPEND=">=dev-lang/lua-5.1[deprecated]"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ net-misc/rsync"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-mandir.patch
+)
+
+S=${WORKDIR}/${PN}-release-${PV}