summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2025-01-27 22:43:21 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-28 17:10:23 +0100
commit39bbb03b44c15e9cdcfa32c515c397cb14b19fac (patch)
treef98fb327db72092cd0bf70cae7bf6fa3b491a1bb /app-admin/setools
parentmedia-sound/qtractor: drop 1.4.0-r1 (diff)
downloadgentoo-39bbb03b44c15e9cdcfa32c515c397cb14b19fac.tar.gz
gentoo-39bbb03b44c15e9cdcfa32c515c397cb14b19fac.tar.bz2
gentoo-39bbb03b44c15e9cdcfa32c515c397cb14b19fac.zip
app-admin/setools: IUSE X -> gui, sync 9999 with 4.5.1
Amends 010e5171befaae2ecf8677b5d8e306bbebf0ae87, ca6cab88cb35b736b29124546e383618ab2e84a2, 34a8e3101f299d9aba988a629a8538801b4a9db0 Bug: https://bugs.gentoo.org/931286 Bug: https://bugs.gentoo.org/933780 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-admin/setools')
-rw-r--r--app-admin/setools/files/setools-4.4.2-remove-gui.patch18
-rw-r--r--app-admin/setools/setools-4.5.1.ebuild10
-rw-r--r--app-admin/setools/setools-9999.ebuild16
3 files changed, 14 insertions, 30 deletions
diff --git a/app-admin/setools/files/setools-4.4.2-remove-gui.patch b/app-admin/setools/files/setools-4.4.2-remove-gui.patch
deleted file mode 100644
index 49d16ec66b56..000000000000
--- a/app-admin/setools/files/setools-4.4.2-remove-gui.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -139,12 +139,10 @@ setup(name='setools',
- author_email='pebenito@ieee.org',
- url='https://github.com/SELinuxProject/setools',
- cmdclass={'build_qhc': QtHelpCommand, 'clean': CleanCommand},
-- packages=['setools', 'setools.checker', 'setools.diff', 'setoolsgui', 'setoolsgui.apol'],
-- scripts=['apol', 'sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta', 'sechecker'],
-+ packages=['setools', 'setools.checker', 'setools.diff'],
-+ scripts=['sediff', 'seinfo', 'seinfoflow', 'sesearch', 'sedta', 'sechecker'],
- data_files=installed_data,
-- package_data={'': ['*.ui', '*.qhc', '*.qch'], 'setools': ['perm_map',
-- 'policyrep.pyi',
-- 'py.typed']},
-+ package_data={'setools': ['perm_map', 'policyrep.pyi', 'py.typed']},
- ext_modules=cythonize(ext_py_mods, include_path=['setools/policyrep'],
- annotate=cython_annotate,
- compiler_directives={"language_level": 3,
diff --git a/app-admin/setools/setools-4.5.1.ebuild b/app-admin/setools/setools-4.5.1.ebuild
index 95837a85a83f..3bf6621425a8 100644
--- a/app-admin/setools/setools-4.5.1.ebuild
+++ b/app-admin/setools/setools-4.5.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
@@ -12,7 +12,7 @@ inherit distutils-r1
DESCRIPTION="Policy Analysis Tools for SELinux"
HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
S="${WORKDIR}/${P}"
@@ -24,7 +24,7 @@ fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="test X"
+IUSE="gui test"
RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
@@ -32,7 +32,7 @@ RDEPEND="${PYTHON_DEPS}
dev-python/setuptools[${PYTHON_USEDEP}]
>=sys-libs/libsepol-3.2:=
>=sys-libs/libselinux-3.2:=
- X? (
+ gui? (
dev-python/pyqt6[gui,widgets,${PYTHON_USEDEP}]
dev-python/pygraphviz[${PYTHON_USEDEP}]
)"
@@ -50,7 +50,7 @@ python_prepare_all() {
sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
die "failed to set lib_dirs"
- use X || PATCHES+=( "${FILESDIR}"/setools-4.5.1-remove-gui.patch )
+ use gui || PATCHES+=( "${FILESDIR}"/${P}-remove-gui.patch )
distutils-r1_python_prepare_all
}
diff --git a/app-admin/setools/setools-9999.ebuild b/app-admin/setools/setools-9999.ebuild
index 16398f7136ad..c7c56b0bb408 100644
--- a/app-admin/setools/setools-9999.ebuild
+++ b/app-admin/setools/setools-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
@@ -12,19 +12,19 @@ inherit distutils-r1
DESCRIPTION="Policy Analysis Tools for SELinux"
HOMEPAGE="https://github.com/SELinuxProject/setools/wiki"
-if [[ ${PV} == 9999 ]] ; then
+if [[ ${PV} == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/setools.git"
S="${WORKDIR}/${P}"
else
SRC_URI="https://github.com/SELinuxProject/setools/releases/download/${PV}/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
S="${WORKDIR}/${PN}"
fi
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="test X"
+IUSE="gui test"
RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
@@ -32,13 +32,15 @@ RDEPEND="${PYTHON_DEPS}
dev-python/setuptools[${PYTHON_USEDEP}]
>=sys-libs/libsepol-3.2:=
>=sys-libs/libselinux-3.2:=
- X? (
+ gui? (
dev-python/pyqt6[gui,widgets,${PYTHON_USEDEP}]
dev-python/pygraphviz[${PYTHON_USEDEP}]
)"
DEPEND="${RDEPEND}"
BDEPEND=">=dev-python/cython-0.29.14[${PYTHON_USEDEP}]
test? (
+ dev-python/pyqt6[gui,testlib,widgets,${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
sys-apps/checkpolicy
)"
@@ -48,7 +50,7 @@ python_prepare_all() {
sed -i "s@^lib_dirs = .*@lib_dirs = ['${ROOT:-/}usr/$(get_libdir)']@" "${S}"/setup.py || \
die "failed to set lib_dirs"
- use X || PATCHES+=( "${FILESDIR}"/setools-4.4.2-remove-gui.patch )
+ use gui || PATCHES+=( "${FILESDIR}"/${PN}-4.5.1-remove-gui.patch )
distutils-r1_python_prepare_all
}