summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-18 17:51:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-18 18:59:06 +0200
commit380af30eb3d4ea67ac716d453bdc282ad766d578 (patch)
treeb4899f2ac5209218993cff300d0d47162ab7388d /app-arch
parentsci-libs/vtk: unrestrict hdf5 (diff)
downloadgentoo-380af30eb3d4ea67ac716d453bdc282ad766d578.tar.gz
gentoo-380af30eb3d4ea67ac716d453bdc282ad766d578.tar.bz2
gentoo-380af30eb3d4ea67ac716d453bdc282ad766d578.zip
app-arch/brotli: Fix tests, PEP517, py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/brotli/Manifest1
-rw-r--r--app-arch/brotli/brotli-1.0.9-r4.ebuild86
-rw-r--r--app-arch/brotli/brotli-9999.ebuild40
3 files changed, 112 insertions, 15 deletions
diff --git a/app-arch/brotli/Manifest b/app-arch/brotli/Manifest
index a7171277c819..3af0701200a7 100644
--- a/app-arch/brotli/Manifest
+++ b/app-arch/brotli/Manifest
@@ -1 +1,2 @@
DIST brotli-1.0.9.tar.gz 486984 BLAKE2B 8b9939d5224396ef33b43e019250ba4bc8949903583615e8dc02c85340fc0a1e2d1632161e00b0ee7355d77f05529ac772f482e05d2089afd71a0bf71e803904 SHA512 b8e2df955e8796ac1f022eb4ebad29532cb7e3aa6a4b6aee91dbd2c7d637eee84d9a144d3e878895bb5e62800875c2c01c8f737a1261020c54feacf9f676b5f5
+DIST brotli-1.0.9.testdata.tar.xz 3771536 BLAKE2B e22a7e926a68b64cf3ddcf90d2381201d0bac6486f28c3a675c83a2a685108491011195faf48df9abd478a011e874df560ae81988348f7605197805cc3be20dd SHA512 d98c48dbc7772959a9cf276b638cf773a05a896c9daf4f6235f7d7fd625490b3f538e0690afcd6968ff81ad3745c7d78419850c2518048c44d73b470bcd08c97
diff --git a/app-arch/brotli/brotli-1.0.9-r4.ebuild b/app-arch/brotli/brotli-1.0.9-r4.ebuild
new file mode 100644
index 000000000000..f206ce927497
--- /dev/null
+++ b/app-arch/brotli/brotli-1.0.9-r4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_OPTIONAL="1"
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit cmake-multilib distutils-r1
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/google/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${P}.testdata.tar.xz
+ )
+ "
+fi
+
+DESCRIPTION="Generic-purpose lossless compression algorithm"
+HOMEPAGE="https://github.com/google/brotli/"
+
+LICENSE="MIT python? ( Apache-2.0 )"
+SLOT="0/$(ver_cut 1)"
+IUSE="python static-libs test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.md CONTRIBUTING.md )
+
+PATCHES=( "${FILESDIR}/${PV}-linker.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+ use python && distutils-r1_src_prepare
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_configure() {
+ cmake-multilib_src_configure
+ use python && distutils-r1_src_configure
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+ use python && distutils-r1_src_compile
+}
+
+python_test() {
+ eunittest -s python -p "*_test.py"
+}
+
+src_test() {
+ cmake-multilib_src_test
+ use python && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ cmake_src_install
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/*.a || die
+ fi
+}
+
+multilib_src_install_all() {
+ use python && distutils-r1_src_install
+}
diff --git a/app-arch/brotli/brotli-9999.ebuild b/app-arch/brotli/brotli-9999.ebuild
index 68bd7f1fb826..f206ce927497 100644
--- a/app-arch/brotli/brotli-9999.ebuild
+++ b/app-arch/brotli/brotli-9999.ebuild
@@ -4,7 +4,9 @@
EAPI=8
DISTUTILS_OPTIONAL="1"
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit cmake-multilib distutils-r1
if [[ ${PV} == *9999* ]] ; then
@@ -12,24 +14,34 @@ if [[ ${PV} == *9999* ]] ; then
inherit git-r3
else
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
- SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${P}.testdata.tar.xz
+ )
+ "
fi
DESCRIPTION="Generic-purpose lossless compression algorithm"
-HOMEPAGE="https://github.com/google/brotli"
+HOMEPAGE="https://github.com/google/brotli/"
LICENSE="MIT python? ( Apache-2.0 )"
SLOT="0/$(ver_cut 1)"
IUSE="python static-libs test"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
RESTRICT="!test? ( test )"
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
DOCS=( README.md CONTRIBUTING.md )
-RDEPEND="python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/${PV}-linker.patch" )
src_prepare() {
cmake_src_prepare
@@ -42,26 +54,21 @@ multilib_src_configure() {
)
cmake_src_configure
}
+
src_configure() {
cmake-multilib_src_configure
use python && distutils-r1_src_configure
}
-multilib_src_compile() {
- cmake_src_compile
-}
src_compile() {
cmake-multilib_src_compile
use python && distutils-r1_src_compile
}
python_test() {
- esetup.py test || die
+ eunittest -s python -p "*_test.py"
}
-multilib_src_test() {
- cmake_src_test
-}
src_test() {
cmake-multilib_src_test
use python && distutils-r1_src_test
@@ -69,8 +76,11 @@ src_test() {
multilib_src_install() {
cmake_src_install
- use static-libs || rm "${ED}"/usr/$(get_libdir)/*.a || die
+ if ! use static-libs; then
+ rm "${ED}"/usr/$(get_libdir)/*.a || die
+ fi
}
+
multilib_src_install_all() {
use python && distutils-r1_src_install
}