summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-27 17:44:24 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-27 17:44:24 +0200
commitde81934515348d027f0f97966140977626668a6a (patch)
treeba0b72fc1e0bd3061af562f725bc1fc82bbba869 /app-arch
parentdev-libs/intel-compute-runtime: add 24.22.29735.21 (diff)
downloadgentoo-de81934515348d027f0f97966140977626668a6a.tar.gz
gentoo-de81934515348d027f0f97966140977626668a6a.tar.bz2
gentoo-de81934515348d027f0f97966140977626668a6a.zip
app-arch/unrar: drop 6.2.12-r1, 7.0.7
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unrar/Manifest2
-rw-r--r--app-arch/unrar/unrar-6.2.12-r1.ebuild79
-rw-r--r--app-arch/unrar/unrar-7.0.7.ebuild79
3 files changed, 0 insertions, 160 deletions
diff --git a/app-arch/unrar/Manifest b/app-arch/unrar/Manifest
index 5b95d324b08a..f635b901417d 100644
--- a/app-arch/unrar/Manifest
+++ b/app-arch/unrar/Manifest
@@ -1,3 +1 @@
-DIST unrar-6.2.12.tar.gz 246918 BLAKE2B 3c7744ee5839b4d87362625a03f30e3cac3d74df988479692023b9c242c136044666ebf0470197b28b95171dae076faecf815ef50caffb747185b8433707612c SHA512 261ac3728f917f36a03c7c3c563d7775abdb06b598ab48a299d837e8fc0ca75ad885ec8e292aeb1775e87e775ed274e9e0f033001598229ec96db69d69824ddb
-DIST unrar-7.0.7.tar.gz 258219 BLAKE2B 06897428ef6ae9b2e6ef3183f25c06447386c7b5ce1c1438ad0119507ccbd2f2b62ce9d45c4dc73241db4440a1f96c7d9a9f3f542c0a7967df9c08b8cd3141cb SHA512 7151a42742d4c34a8f03c58dae471f80788b76adbb52188759b7fc7357757f88fa9d980de006ce48732c40f326b92b79fb069e807c2b66d4387ee60433a8accb
DIST unrar-7.0.9.tar.gz 258287 BLAKE2B 4933d62c8b7ea227b5eee8ce078a08cbe7534f35641ee0ce33bdd246f1045c65f773894d5868738b2174ea2bb2858745b5bd31dc5f958ef70188bcb805165300 SHA512 4dff760bd69275dcd9bacac7a8fa9a6e68e2d047ea3775abc16a80d9a6e277b686153faafb1b711582d86eabfdf3254c601d9f585b28104dbd85ece4868876ed
diff --git a/app-arch/unrar/unrar-6.2.12-r1.ebuild b/app-arch/unrar/unrar-6.2.12-r1.ebuild
deleted file mode 100644
index 66957ceed24c..000000000000
--- a/app-arch/unrar/unrar-6.2.12-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib toolchain-funcs
-
-MY_PN="${PN}src"
-
-DESCRIPTION="Uncompress rar files"
-HOMEPAGE="https://www.rarlab.com/rar_add.htm"
-SRC_URI="https://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/unrar"
-
-LICENSE="unRAR"
-SLOT="0/6" # subslot = soname version
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-PATCHES=( "${FILESDIR}/${PN}-6.2.6-honor-flags.patch" )
-
-src_prepare() {
- default
-
- local sed_args=( -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" )
- if [[ ${CHOST} == *-darwin* ]] ; then
- sed_args+=( -e "s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libunrar$(get_libname ${PV%.*.*}):" )
- else
- sed_args+=( -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" )
- fi
- sed -i "${sed_args[@]}" makefile || die
-}
-
-src_configure() {
- mkdir -p build-{lib,bin} || die
- printf 'VPATH = ..\ninclude ../makefile' > build-lib/Makefile || die
- cp build-{lib,bin}/Makefile || die
-}
-
-src_compile() {
- unrar_make() {
- emake AR="$(tc-getAR)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
- }
-
- unrar_make CXXFLAGS+=" -fPIC" -C build-lib lib
- ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname) || die
- ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname ${PV}) || die
-
- unrar_make -C build-bin
-}
-
-src_install() {
- dobin build-bin/unrar
- dodoc readme.txt
-
- dolib.so build-lib/libunrar*
-
- # unrar doesn't officially install headers, but unofficially, software
- # depends on it anyway. There is no standard for where to install them,
- # but the most common location (shared by nearly all vendors) is "unrar".
- # FreeBSD alone uses "libunrar". Gentoo formerly used "libunrar6" and
- # had a compat symlink for FreeBSD, then passed the compat location in
- # ./configure scripts e.g. for sys-fs/rar2fs. Software in the wild
- # seems to expect either "unrar" or "libunrar".
- # See: https://bugs.gentoo.org/916036
- #
- # We now use the "standard" (hah) location, and keep the compat symlink but
- # change the destination. The version-suffixed location lacks utility, but
- # we would keep it if we could, just in case -- unfortunately portage is
- # buggy: https://bugs.gentoo.org/834600
- #
- # Hopefully, no one has ever actually used it and therefore this does not
- # matter. The odds are on our side, since it periodically changed location
- # arbitrarily.
- insinto /usr/include/unrar
- doins *.hpp
- dosym unrar /usr/include/libunrar
-
- find "${ED}" -type f -name "*.a" -delete || die
-}
diff --git a/app-arch/unrar/unrar-7.0.7.ebuild b/app-arch/unrar/unrar-7.0.7.ebuild
deleted file mode 100644
index dcc656ed9f4f..000000000000
--- a/app-arch/unrar/unrar-7.0.7.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib toolchain-funcs
-
-MY_PN="${PN}src"
-
-DESCRIPTION="Uncompress rar files"
-HOMEPAGE="https://www.rarlab.com/rar_add.htm"
-SRC_URI="https://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/unrar"
-
-LICENSE="unRAR"
-SLOT="0/7" # subslot = soname version
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-PATCHES=( "${FILESDIR}/${PN}-6.2.6-honor-flags.patch" )
-
-src_prepare() {
- default
-
- local sed_args=( -e "/libunrar/s:.so:$(get_libname ${PV%.*.*}):" )
- if [[ ${CHOST} == *-darwin* ]] ; then
- sed_args+=( -e "s:-shared:-dynamiclib -install_name ${EPREFIX}/usr/$(get_libdir)/libunrar$(get_libname ${PV%.*.*}):" )
- else
- sed_args+=( -e "s:-shared:& -Wl,-soname -Wl,libunrar$(get_libname ${PV%.*.*}):" )
- fi
- sed -i "${sed_args[@]}" makefile || die
-}
-
-src_configure() {
- mkdir -p build-{lib,bin} || die
- printf 'VPATH = ..\ninclude ../makefile' > build-lib/Makefile || die
- cp build-{lib,bin}/Makefile || die
-}
-
-src_compile() {
- unrar_make() {
- emake AR="$(tc-getAR)" CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" STRIP=true "$@"
- }
-
- unrar_make CXXFLAGS+=" -fPIC" -C build-lib lib
- ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname) || die
- ln -s libunrar$(get_libname ${PV%.*.*}) build-lib/libunrar$(get_libname ${PV}) || die
-
- unrar_make -C build-bin
-}
-
-src_install() {
- dobin build-bin/unrar
- dodoc readme.txt
-
- dolib.so build-lib/libunrar*
-
- # unrar doesn't officially install headers, but unofficially, software
- # depends on it anyway. There is no standard for where to install them,
- # but the most common location (shared by nearly all vendors) is "unrar".
- # FreeBSD alone uses "libunrar". Gentoo formerly used "libunrar6" and
- # had a compat symlink for FreeBSD, then passed the compat location in
- # ./configure scripts e.g. for sys-fs/rar2fs. Software in the wild
- # seems to expect either "unrar" or "libunrar".
- # See: https://bugs.gentoo.org/916036
- #
- # We now use the "standard" (hah) location, and keep the compat symlink but
- # change the destination. The version-suffixed location lacks utility, but
- # we would keep it if we could, just in case -- unfortunately portage is
- # buggy: https://bugs.gentoo.org/834600
- #
- # Hopefully, no one has ever actually used it and therefore this does not
- # matter. The odds are on our side, since it periodically changed location
- # arbitrarily.
- insinto /usr/include/unrar
- doins *.hpp
- dosym unrar /usr/include/libunrar
-
- find "${ED}" -type f -name "*.a" -delete || die
-}