summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-27 23:12:55 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-28 00:42:20 +0200
commit14756754f28deac019f52e7623e74b91f3ebf6bb (patch)
tree277cb9dfd208e639c116c176aae048f427c23544 /app-containers/earthly
parentapp-containers/earthly: drop old 0.8.9 (diff)
downloadgentoo-14756754f28deac019f52e7623e74b91f3ebf6bb.tar.gz
gentoo-14756754f28deac019f52e7623e74b91f3ebf6bb.tar.bz2
gentoo-14756754f28deac019f52e7623e74b91f3ebf6bb.zip
app-containers/earthly: drop old 0.8.10
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/earthly')
-rw-r--r--app-containers/earthly/Manifest2
-rw-r--r--app-containers/earthly/earthly-0.8.10.ebuild77
2 files changed, 0 insertions, 79 deletions
diff --git a/app-containers/earthly/Manifest b/app-containers/earthly/Manifest
index 0ed72d29e98e..44633e74dbdf 100644
--- a/app-containers/earthly/Manifest
+++ b/app-containers/earthly/Manifest
@@ -1,5 +1,3 @@
-DIST earthly-0.8.10-deps.tar.zst 180360414 BLAKE2B c734773657da1194f2708212aca3e8fa2ec7869350c47c5ee5b52c2931e56ddce9292c1670f7d8ce089a8f6597e4fa25b29b1e57304c248ab29f783e040691f1 SHA512 2745f08330403e4976fb970ba2e7bbac769b20111571c800e9e774a4486b9da816d91da8d83e2b4fcc53627184a7c054e9f66c182cba9af5a9b7d6e044ad9a19
-DIST earthly-0.8.10.tar.gz 8089062 BLAKE2B 0d3e29b84121d42995c8171a4e39815fb752d2aa36eb00efd0286a8cbd014d1b64db576f654104412433e5403812f1fa8bed2bbcfb981589fdab1fbc30e4dc1f SHA512 1449953fd705f3547f4da9eb53a674a6ef37d30a669b758a9abad5800decef650f57f3ec4436de191c8aff09d4c1b4b4bdaf5e591af1a06d568fdd18ab3670f9
DIST earthly-0.8.11-deps.tar.zst 180367967 BLAKE2B 3d321cc6177d4e113662b1ed99b190dd2b344c6295a22d21b278e3a6620c1669eea3572ad6f1300335e23e752b8b029808411604bfef5cdd53c0e353cac7cc31 SHA512 b238ffd6996f17ce1f4e87ae3e4705d84cab1161143f06074cedd9bbf89a2feecbace3efe5b4a827471388ff80eb265febc4c59ee2acca9ebf02a8a301974702
DIST earthly-0.8.11.tar.gz 8089764 BLAKE2B 2d110482b2643498e0fd8ee03dba5a2d58d9a8d3ceea9507582184e3fe59ae9851fec1fbd16c636b23d2e7044a8375fc6fc3692431f637a043e71c2c2bab572f SHA512 fd92f6a86efd8576c1c75367f4b6e211c04615aaf5504f86192f85b751c628801439c22925797e0b2b775fa02b555b200a728085818e1d49d09f98847e5a99c0
DIST earthly-0.8.12-deps.tar.xz 163755972 BLAKE2B 6d5e7e2d157b54818bebca7cc0b57be23be4581660bae8002bb90983cc9478d9d05ebea3dd102123ced6c1f1a8b94f93ca0868c040defa1fb5f0137f901b1c50 SHA512 bcfc4eecfceefcf5677f145475406fe4fef9d3a70c177ea657f2f0eec7227c752fcc01b129c001fbb8d9fa6ba934a6425b0fb0957b6812d2f751e7d3b99dd0a2
diff --git a/app-containers/earthly/earthly-0.8.10.ebuild b/app-containers/earthly/earthly-0.8.10.ebuild
deleted file mode 100644
index 3764c02e729f..000000000000
--- a/app-containers/earthly/earthly-0.8.10.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Git commit SHA is needed at runtime by earthly to pull and bootstrap images.
-if [[ "${PV}" == 0.8.10 ]] ; then
- COMMIT_SHA=9050356a89d53c96ff94b6a46107274426353441
-else
- die 'Could not detect "COMMIT_SHA", please update the ebuild.'
-fi
-
-inherit go-module unpacker
-
-DESCRIPTION="Build automation tool that executes in containers"
-HOMEPAGE="https://earthly.dev/
- https://github.com/earthly/earthly/"
-SRC_URI="
- https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz
- https://dev.gentoo.org/~xgqt/distfiles/deps/${P}-deps.tar.zst
-"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- || (
- app-containers/docker
- app-containers/podman
- )
-"
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-src_unpack() {
- unpacker "${P}-deps.tar.zst"
-
- go-module_src_unpack
-}
-
-src_compile() {
- local -r go_tags="dfrunmount,dfrunsecurity,dfsecrets,dfssh,dfrunnetwork,dfheredoc,forceposix"
- local -r go_ldflags="
- -X main.DefaultBuildkitdImage=docker.io/earthly/buildkitd:v${PV}
- -X main.GitSha=${COMMIT_SHA}
- -X main.Version=v${PV}
- "
- local -a -r go_buildargs=(
- -tags "${go_tags}"
- -ldflags "${go_ldflags}"
- -o ./bin/
- )
- ego build "${go_buildargs[@]}" ./cmd/...
-}
-
-src_install() {
- exeinto /usr/bin
- doexe bin/earthly
- newexe bin/debugger earthly-debugger
-
- einstalldocs
-}
-
-pkg_postinst() {
- if has_version "app-containers/podman" ; then
- ewarn "Podman is supported but not recommended."
- ewarn "If issues arise, then please try running earthly with docker."
- fi
-
- if has_version "app-containers/podman[rootless]" ; then
- ewarn "Running podman in rootless mode is not supported because"
- ewarn "earthly/dind and earthly/buildkit require privileged access."
- ewarn "For more info see: https://docs.earthly.dev/docs/guides/podman/"
- fi
-}