summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-04-04 23:55:09 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-04-04 23:55:09 -0500
commit83c48ba85370e0bac8bc98432ca4b5f699a2573a (patch)
treef5675f46ee554218f3cabd109b751caacdcb3e0d /app-crypt/certbot-apache
parentapp-crypt/certbot: 0.23.0 bup (diff)
downloadgentoo-83c48ba85370e0bac8bc98432ca4b5f699a2573a.tar.gz
gentoo-83c48ba85370e0bac8bc98432ca4b5f699a2573a.tar.bz2
gentoo-83c48ba85370e0bac8bc98432ca4b5f699a2573a.zip
app-crypt/certbot-apache: 0.23.0 bup
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-0.23.0.ebuild38
-rw-r--r--app-crypt/certbot-apache/certbot-apache-9999.ebuild6
3 files changed, 42 insertions, 3 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 0f905dc2dc3a..05674ab701d4 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -2,3 +2,4 @@ DIST certbot-0.20.0.tar.gz 1108139 BLAKE2B 6af07dd245912741592761bd11160c081e278
DIST certbot-0.21.1.tar.gz 1105663 BLAKE2B 7c36ec0504a144a2325528079374d103f6214252c01ba0bcaf26378950fe5cd54010abe756d80b1c0c30740442a184417f0b2bd7ffea91edeb70c59dfee2349e SHA512 6f3ffba7dc06bcc2a6b9835906331753ee2715192e7a49562314480069f22e4a66bb26f04dc4bbdfb0ab40998220d0c9b77fb0351e042116b02996fb2da699d2
DIST certbot-0.22.0.tar.gz 1128134 BLAKE2B d4874bca6ac9f992d54b8fbab975bc020f448ed83896d0088c8ba0f1547fbc02a783038992408b9090fde4ad8386c81d85511094abcd42bc79b8883f05d4600c SHA512 406810e29a2637c420b9a8a3feb3a2ffb77bd740419cbcf46d10ab152a7252c765c058481b2a1f9a96cc426a9ae018bf90540fc0ebd54be1c8822c528cf1b605
DIST certbot-0.22.2.tar.gz 1128517 BLAKE2B 0b95ee9ab6b69b5d511b737d1cfc1eff543f1f0abeba9e60429dfe2dc389b39e19df10c77ea7c90ad8795640ae7602a7bc239c57cd1734863bf19d1f0c5eab67 SHA512 ca26be78d29728fc5c20a5290f2dde4d1f2090b7e2829c0b312acac4741ef56440cc21a9db77e3e0cfe59ce0f1f0ab2165cb6823af8a4e2a4528060ad683ffe9
+DIST certbot-0.23.0.tar.gz 1144448 BLAKE2B 820c4e3a0245a4ccda90884e38093d4f95ebf8c06ccb93c80a277a69074a6ab3bac3451f4e8f9af6c1c36edd9d871e10de9240d847e6eeac5fb8e0fbcdb3cdcb SHA512 397562fa7f5ef5daea8ccf70dc21898f8b792dc6a07aa24035fa378da8af3dd5d0734c3fbf6080c28d17f050db46ec0ea637be81d4ce648fa5ab2add2cfd41ed
diff --git a/app-crypt/certbot-apache/certbot-apache-0.23.0.ebuild b/app-crypt/certbot-apache/certbot-apache-0.23.0.ebuild
new file mode 100644
index 000000000000..2f2c9cd3e8a5
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-0.23.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=">=app-crypt/certbot-0.21.1[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.21.1[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ nosetests || die
+}
diff --git a/app-crypt/certbot-apache/certbot-apache-9999.ebuild b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
index 6dd43da7e5b4..2f2c9cd3e8a5 100644
--- a/app-crypt/certbot-apache/certbot-apache-9999.ebuild
+++ b/app-crypt/certbot-apache/certbot-apache-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -23,8 +23,8 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE="test"
-RDEPEND="~app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- ~app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+RDEPEND=">=app-crypt/certbot-0.21.1[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.21.1[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/python-augeas[${PYTHON_USEDEP}]
dev-python/zope-component[${PYTHON_USEDEP}]