summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-08-27 14:44:28 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-08-27 14:44:28 +0200
commitd976cf869aafda1fac11f7946328b77c7b29f934 (patch)
tree0ef31e95f2e23ef16986610ace0113d9cf2d901f /app-crypt/kbfs/kbfs-9999.ebuild
parentapp-admin/awscli: keyword 1.25.60 for ~riscv (diff)
downloadgentoo-d976cf869aafda1fac11f7946328b77c7b29f934.tar.gz
gentoo-d976cf869aafda1fac11f7946328b77c7b29f934.tar.bz2
gentoo-d976cf869aafda1fac11f7946328b77c7b29f934.zip
app-crypt/kbfs: treeclean
Closes: https://bugs.gentoo.org/682346 Closes: https://bugs.gentoo.org/844592 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'app-crypt/kbfs/kbfs-9999.ebuild')
-rw-r--r--app-crypt/kbfs/kbfs-9999.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-crypt/kbfs/kbfs-9999.ebuild b/app-crypt/kbfs/kbfs-9999.ebuild
deleted file mode 100644
index d6752264b28c..000000000000
--- a/app-crypt/kbfs/kbfs-9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit git-r3 golang-build systemd
-
-DESCRIPTION="Keybase Filesystem (KBFS)"
-HOMEPAGE="https://keybase.io/docs/kbfs"
-EGIT_REPO_URI="https://github.com/keybase/kbfs.git"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="git"
-
-DEPEND=""
-RDEPEND="
- app-crypt/gnupg
- sys-fs/fuse:0=
- "
-
-src_unpack() {
- git-r3_src_unpack
- mkdir -vp "${S}/src/github.com/keybase" || die
- ln -vs "${S}" "${S}/src/github.com/keybase/kbfs" || die
-}
-
-src_compile() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/kbfsfuse" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/kbfsgit/git-remote-keybase" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/git-remote-keybase" \
- golang-build_src_compile
- EGO_PN="github.com/keybase/kbfs/redirector" \
- EGO_BUILD_FLAGS="-tags production -o ${T}/keybase-redirector" \
- golang-build_src_compile
-}
-
-src_test() {
- EGO_PN="github.com/keybase/kbfs/kbfsfuse" \
- golang-build_src_test
-}
-
-src_install() {
- dobin "${T}/kbfsfuse"
- dobin "${T}/git-remote-keybase"
- dobin "${T}/keybase-redirector"
- systemd_douserunit "${S}/packaging/linux/systemd/kbfs.service"
-}