summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:17:38 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:17:38 +0100
commit43bdbf3fb080f6a30c1f4173867e1f10d71152f8 (patch)
tree789afd2afff9f31fe9fa083b3ac3a338818c0ec6 /app-crypt/simple-tpm-pk11
parentapp-crypt/libu2f-host: disable static libs (diff)
downloadgentoo-43bdbf3fb080f6a30c1f4173867e1f10d71152f8.tar.gz
gentoo-43bdbf3fb080f6a30c1f4173867e1f10d71152f8.tar.bz2
gentoo-43bdbf3fb080f6a30c1f4173867e1f10d71152f8.zip
app-crypt/simple-tpm-pk11: disable static libs
Closes: https://bugs.gentoo.org/733008 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt/simple-tpm-pk11')
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
index 1c0e8dc2f60f..bc22e3b9faea 100644
--- a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -34,3 +34,12 @@ src_prepare() {
eapply_user
eautoreconf
}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}