summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2019-01-01 00:02:18 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2019-01-01 00:08:55 +0200
commit7a8bbaf6fbcd80d4ed98e6fa85ca47a29e163526 (patch)
tree45a046dd00e97874213e6e8d778303103b233f9e /app-crypt/tpm2-abrmd/files
parentapp-crypt/tpm2-tss: prune libtool files (diff)
downloadgentoo-7a8bbaf6fbcd80d4ed98e6fa85ca47a29e163526.tar.gz
gentoo-7a8bbaf6fbcd80d4ed98e6fa85ca47a29e163526.tar.bz2
gentoo-7a8bbaf6fbcd80d4ed98e6fa85ca47a29e163526.zip
app-crypt/tpm2-abrmd: initial add
Signed-off-by: Alon Bar-Lev <alonbl@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-crypt/tpm2-abrmd/files')
-rw-r--r--app-crypt/tpm2-abrmd/files/tpm2-abrmd-2.0.3-build.patch32
-rw-r--r--app-crypt/tpm2-abrmd/files/tpm2-abrmd.confd1
-rw-r--r--app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd15
3 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/tpm2-abrmd/files/tpm2-abrmd-2.0.3-build.patch b/app-crypt/tpm2-abrmd/files/tpm2-abrmd-2.0.3-build.patch
new file mode 100644
index 000000000000..72e823405e91
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/files/tpm2-abrmd-2.0.3-build.patch
@@ -0,0 +1,32 @@
+diff --git a/configure.ac b/configure.ac
+index ecbc3bb..5973ff5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -135,7 +135,6 @@ AM_CONDITIONAL([ENABLE_INTEGRATION],[test "x$enable_integration" = "xyes"])
+ # these macros are defined in m4/flags.m4
+ AX_ADD_COMPILER_FLAG([-Wall])
+ AX_ADD_COMPILER_FLAG([-Wextra])
+-AX_ADD_COMPILER_FLAG([-Werror])
+ AX_ADD_COMPILER_FLAG([-std=gnu99])
+ AX_ADD_COMPILER_FLAG([-Wformat])
+ AX_ADD_COMPILER_FLAG([-Wformat-security])
+@@ -143,19 +142,9 @@ AX_ADD_COMPILER_FLAG([-Wno-missing-braces])
+ # work around for Glib usage of function pointers type casting
+ # https://bugzilla.gnome.org/show_bug.cgi?id=793272
+ AX_ADD_COMPILER_FLAG([-Wno-cast-function-type])
+-AX_ADD_COMPILER_FLAG([-fdata-sections])
+-AX_ADD_COMPILER_FLAG([-ffunction-sections])
+-AX_ADD_COMPILER_FLAG([-fstack-protector-all])
+-AX_ADD_COMPILER_FLAG([-fpic])
+-AX_ADD_COMPILER_FLAG([-fPIC])
+ AX_ADD_PREPROC_FLAG([-D_GNU_SOURCE])
+ AX_ADD_PREPROC_FLAG([-U_FORTIFY_SOURCE])
+ AX_ADD_PREPROC_FLAG([-D_FORTIFY_SOURCE=2])
+-AX_ADD_LINK_FLAG([-Wl,--gc-sections])
+-AX_ADD_LINK_FLAG([-Wl,--no-undefined])
+-AX_ADD_LINK_FLAG([-Wl,-z,noexecstack])
+-AX_ADD_LINK_FLAG([-Wl,-z,now])
+-AX_ADD_LINK_FLAG([-Wl,-z,relro])
+
+ AC_SUBST([PATH])
+
diff --git a/app-crypt/tpm2-abrmd/files/tpm2-abrmd.confd b/app-crypt/tpm2-abrmd/files/tpm2-abrmd.confd
new file mode 100644
index 000000000000..619e3dfde776
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/files/tpm2-abrmd.confd
@@ -0,0 +1 @@
+TPM2_ABRMD_ARGS=
diff --git a/app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd b/app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd
new file mode 100644
index 000000000000..0272921dcbd7
--- /dev/null
+++ b/app-crypt/tpm2-abrmd/files/tpm2-abrmd.initd
@@ -0,0 +1,15 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+description="TPM2 Access Broker & Resource Manager"
+command="/usr/sbin/tpm2-abrmd"
+command_args="${TPM2_ABRMD_ARGS} --logger=syslog"
+command_background=1
+command_user="tss:tss"
+pidfile="/var/run/${RC_SVCNAME}.pid"
+
+depend() {
+ use logger
+ after coldplug
+}