summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-03-28 10:21:45 -0500
committerJoonas Niilola <juippis@gentoo.org>2022-04-23 09:25:03 +0300
commitf69fef96f229fdbe13bd54b68408060278f4d53b (patch)
tree9fa70708e38db7ffaae0e9c9e40efd8264686d0a /app-crypt/tpm2-pkcs11
parentdev-python/tpm2-pytss: initial import v1.1.0 (diff)
downloadgentoo-f69fef96f229fdbe13bd54b68408060278f4d53b.tar.gz
gentoo-f69fef96f229fdbe13bd54b68408060278f4d53b.tar.bz2
gentoo-f69fef96f229fdbe13bd54b68408060278f4d53b.zip
app-crypt/tpm2-pkcs11: add 1.8.0
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-crypt/tpm2-pkcs11')
-rw-r--r--app-crypt/tpm2-pkcs11/Manifest1
-rw-r--r--app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/tpm2-pkcs11/Manifest b/app-crypt/tpm2-pkcs11/Manifest
index b9c3a72ad07a..92062e22dd2c 100644
--- a/app-crypt/tpm2-pkcs11/Manifest
+++ b/app-crypt/tpm2-pkcs11/Manifest
@@ -1 +1,2 @@
DIST tpm2-pkcs11-1.7.0.tar.gz 1386693 BLAKE2B bf53a76be712bda374a8d107910440bab087fdb6c34fee3c748128d471a7a84b08f887ff97c8cdfef632679dd4343cf020e9459b96553cd5feecf76e65d6e290 SHA512 eb2736a7ef00fefa91bb70cc96d94d1c7b6ce3701ab12301658b7b076d8fca93bc590c7cdba5a84934b6bd09dad252b13670804c686e76a65b03c7ef6d96427d
+DIST tpm2-pkcs11-1.8.0.tar.gz 1393977 BLAKE2B c959e9e593dde903eac4b26ac85a39d1c73bfb9b6be558d7338dae1a710eb836385b08ddca27689f0573242d40ee072fa5d6685186a50e10ea42b8679389cf92 SHA512 599feb4d888c25a3359927b1d408f9ce85ba69d8a0e7af7ae9f3736e8940ec8d5f58b3094bef3b6515c0b1810249ea98cd73dbce592cb63de3b45ff976adda80
diff --git a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild
new file mode 100644
index 000000000000..5a58280d4e3b
--- /dev/null
+++ b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1
+
+DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
+HOMEPAGE="https://tpm2-software.github.io/"
+SRC_URI="https://github.com/tpm2-software/tpm2-pkcs11/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="fapi test"
+REQUIRED_USE="( ${PYTHON_REQUIRED_USE} )"
+
+# Units tests only for now
+RESTRICT="!test? ( test )"
+
+RDEPEND="${PYTHON_DEPS}
+ app-crypt/p11-kit
+ app-crypt/tpm2-abrmd
+ app-crypt/tpm2-tools[fapi?]
+ !fapi? ( app-crypt/tpm2-tss:= )
+ fapi? ( >=app-crypt/tpm2-tss-3.0.1:=[fapi] )
+ dev-db/sqlite:3
+ dev-libs/libyaml
+ dev-libs/openssl:=
+ $(python_gen_cond_dep '
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tpm2-pytss[${PYTHON_USEDEP}]
+ ')
+"
+
+DEPEND="test? ( dev-util/cmocka )
+ ${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable fapi) \
+ $(use_enable test unit)
+}
+
+src_install() {
+ default
+ python_domodule tools/tpm2_pkcs11
+ python_newscript tools/tpm2_ptool.py tpm2_ptool
+ find "${ED}" -name '*.la' -delete || die
+}