summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-09 11:31:26 +0100
committerSam James <sam@gentoo.org>2024-10-09 11:31:26 +0100
commit5180e4596a18e5f17b23364643c9d50b52e33f21 (patch)
tree7bd728b60169e705fd84566a476dde5f36826858 /app-crypt
parentdev-cpp/benchmark: Stabilize 1.9.0 ppc64, #940640 (diff)
downloadgentoo-5180e4596a18e5f17b23364643c9d50b52e33f21.tar.gz
gentoo-5180e4596a18e5f17b23364643c9d50b52e33f21.tar.bz2
gentoo-5180e4596a18e5f17b23364643c9d50b52e33f21.zip
app-crypt/certbot: fix deprecation warning name
Closes: https://bugs.gentoo.org/937889 Fixes: 6af2e1684b64a9e0d621903d02de17e3b8540a67 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot/certbot-2.11.0-r2.ebuild (renamed from app-crypt/certbot/certbot-2.11.0-r1.ebuild)0
-rw-r--r--app-crypt/certbot/files/certbot-2.11.0-workaround-cryptography-deprecation-warnings.patch2
2 files changed, 1 insertions, 1 deletions
diff --git a/app-crypt/certbot/certbot-2.11.0-r1.ebuild b/app-crypt/certbot/certbot-2.11.0-r2.ebuild
index 7787932d9c6a..7787932d9c6a 100644
--- a/app-crypt/certbot/certbot-2.11.0-r1.ebuild
+++ b/app-crypt/certbot/certbot-2.11.0-r2.ebuild
diff --git a/app-crypt/certbot/files/certbot-2.11.0-workaround-cryptography-deprecation-warnings.patch b/app-crypt/certbot/files/certbot-2.11.0-workaround-cryptography-deprecation-warnings.patch
index b0d59594d03f..ecaf4830eb24 100644
--- a/app-crypt/certbot/files/certbot-2.11.0-workaround-cryptography-deprecation-warnings.patch
+++ b/app-crypt/certbot/files/certbot-2.11.0-workaround-cryptography-deprecation-warnings.patch
@@ -23,7 +23,7 @@ https://bugs.gentoo.org/937889
+ with warnings.catch_warnings():
+ # Workaround for deprecation warnings w/ newer cryptography
+ # https://github.com/certbot/certbot/issues/9967 (bug #937889)
-+ warnings.filterwarnings("ignore",category=DeprecationWarning)
++ warnings.filterwarnings("ignore", category=CryptographyDeprecationWarning)
+
+ if not response_ocsp.this_update:
+ raise AssertionError('param thisUpdate is not set.')