summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:06 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:06 +0200
commit92c1cf96a0581b3a05a92c1aaf59f757a0777126 (patch)
tree0f5c575c36a24046a768b05a0d1955e7ec56fe59 /app-crypt
parentapp-crypt/johntheripper: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-92c1cf96a0581b3a05a92c1aaf59f757a0777126.tar.gz
gentoo-92c1cf96a0581b3a05a92c1aaf59f757a0777126.tar.bz2
gentoo-92c1cf96a0581b3a05a92c1aaf59f757a0777126.zip
app-crypt/libb2: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/libb2/libb2-0.98.1-r2.ebuild11
-rw-r--r--app-crypt/libb2/libb2-0.98.1-r3.ebuild9
2 files changed, 11 insertions, 9 deletions
diff --git a/app-crypt/libb2/libb2-0.98.1-r2.ebuild b/app-crypt/libb2/libb2-0.98.1-r2.ebuild
index e51689e6a0e3..046c9525d1f6 100644
--- a/app-crypt/libb2/libb2-0.98.1-r2.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,11 +24,12 @@ RDEPEND="${DEPEND}"
S=${WORKDIR}/${PN}-${GITHASH}
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if [[ ${MERGE_TYPE} != "binary" ]] && use openmp && ! tc-has-openmp; then
- ewarn "You are using a compiler without OpenMP support"
- die "Need an OpenMP capable compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
diff --git a/app-crypt/libb2/libb2-0.98.1-r3.ebuild b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
index 24a130333c1a..c0da5c1930f6 100644
--- a/app-crypt/libb2/libb2-0.98.1-r3.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1-r3.ebuild
@@ -26,11 +26,12 @@ S=${WORKDIR}/${PN}-${GITHASH}
PATCHES=( "${FILESDIR}"/${P}-distcc.patch )
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if [[ ${MERGE_TYPE} != "binary" ]] && use openmp && ! tc-has-openmp; then
- ewarn "You are using a compiler without OpenMP support"
- die "Need an OpenMP capable compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {