summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre-Olivier Mercier <nemunaire@nemunai.re>2018-03-21 20:06:39 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-24 14:10:45 +0100
commita031d3b2a7ae4e854eee9c1fe135db33a893441b (patch)
tree3025c5ed346d90289675f17d75cec76b6ebeae67 /app-crypt
parentdev-ruby/rrdtool-bindings: Use HTTPS. (diff)
downloadgentoo-a031d3b2a7ae4e854eee9c1fe135db33a893441b.tar.gz
gentoo-a031d3b2a7ae4e854eee9c1fe135db33a893441b.tar.bz2
gentoo-a031d3b2a7ae4e854eee9c1fe135db33a893441b.zip
app-crypt/moolticute: bump to 0.12.7
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/moolticute/Manifest1
-rw-r--r--app-crypt/moolticute/moolticute-0.12.7.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/moolticute/Manifest b/app-crypt/moolticute/Manifest
index 80569395c5bf..4d7f4cbe64e0 100644
--- a/app-crypt/moolticute/Manifest
+++ b/app-crypt/moolticute/Manifest
@@ -1 +1,2 @@
DIST moolticute-0.11.11_beta.tar.gz 5363395 BLAKE2B 0d37c3af1fb79510a7203951d28426897ee6ed4ddf53d8ac84013ca1eb939a90b4ab6008a47a2d8974588dcc0fc7109e3a7e5770783c9312ed4335e14a016b18 SHA512 5b9fd72c52eec6755474a187dcd7af9ead89e2c08504d25ab6e4ab36991e032699cb8a9e02f402f7e5e551238bcfd225d2b5415945df07ec2bde7625c7041659
+DIST moolticute-0.12.7.tar.gz 5364075 BLAKE2B a85a18264e5658a96454d4b934cca1b62b63b2d1b90352fe750f973e28dd2da78d0a95d3103d4e213d9bb96b76d28c79d6d77127a6c85078036b63e61889afe0 SHA512 f7db56c9bdf6d3f8d1ad573f37f0c394b53fd2acc1f257f2f8b113af1c1a050f40a3cdbf7d559cb45eb5e61533bae084f0b574db43da1598bfd056131df8edd9
diff --git a/app-crypt/moolticute/moolticute-0.12.7.ebuild b/app-crypt/moolticute/moolticute-0.12.7.ebuild
new file mode 100644
index 000000000000..b5153ad45a3e
--- /dev/null
+++ b/app-crypt/moolticute/moolticute-0.12.7.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/mooltipass/moolticute.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/mooltipass/moolticute/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+inherit gnome2-utils qmake-utils udev
+
+DESCRIPTION="Mooltipass crossplatform daemon/tools"
+HOMEPAGE="https://github.com/mooltipass/moolticute"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/libusb-1.0.20
+ >=dev-qt/qtcore-5.6:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ default
+
+ # Fill version.h with package version
+ if [[ ${PV} != 9999* ]]; then
+ sed -i "s/\"git\"/\"v${PV/_/-}\"/" src/version.h || die
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="/usr" Moolticute.pro
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ udev_dorules "${FILESDIR}/50-mooltipass.rule"
+ newinitd "${FILESDIR}/moolticuted.init" moolticuted
+}
+
+pkg_postinst() {
+ udev_reload
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}