summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-06 12:27:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-06 12:30:30 +0200
commite0d1000254ca011048a699869ec90bec4b672d75 (patch)
treeb98f98d979ce35bda633f48d69c6cbcd2544db4a /app-doc/python-docs/python-docs-3.10.11.ebuild
parentdev-python/notebook: Stabilize 6.5.4 arm64, #904813 (diff)
downloadgentoo-e0d1000254ca011048a699869ec90bec4b672d75.tar.gz
gentoo-e0d1000254ca011048a699869ec90bec4b672d75.tar.bz2
gentoo-e0d1000254ca011048a699869ec90bec4b672d75.zip
Move {dev-python → app-doc}/python-docs
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc/python-docs/python-docs-3.10.11.ebuild')
-rw-r--r--app-doc/python-docs/python-docs-3.10.11.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-doc/python-docs/python-docs-3.10.11.ebuild b/app-doc/python-docs/python-docs-3.10.11.ebuild
new file mode 100644
index 000000000000..e0ae576a6a47
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}