summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2022-02-27 02:19:31 +0300
committerSam James <sam@gentoo.org>2022-02-27 00:52:55 +0000
commite52e53152c51cb41521c3b4df36d51a12b258496 (patch)
tree78f303ffdf7f327ea2f0dd79f04c3d7047722845 /app-doc
parentapp-doc/gimp-help: add python-3.10 compatibility (diff)
downloadgentoo-e52e53152c51cb41521c3b4df36d51a12b258496.tar.gz
gentoo-e52e53152c51cb41521c3b4df36d51a12b258496.tar.bz2
gentoo-e52e53152c51cb41521c3b4df36d51a12b258496.zip
app-doc/gimp-help: add python_export_utf8_locale
Closes: https://bugs.gentoo.org/833566 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/24290 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild b/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
index 719b556896f2..d04db34df635 100644
--- a/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
+++ b/app-doc/gimp-help/gimp-help-2.10.0-r2.ebuild
@@ -33,3 +33,10 @@ python_check_deps() {
src_configure() {
econf --without-gimp
}
+
+src_compile() {
+ # See bug: 833566
+ python_export_utf8_locale
+ # If affected with bug: 677198 then set "emake -j1"
+ emake
+}