summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-04 23:33:16 -0400
committerSam James <sam@gentoo.org>2024-06-06 01:44:47 +0100
commit9d938dc7549a99a9a266434a9f956d64a205778d (patch)
treecb5c3663240d5ce3133b2c3961d9a117ee0c9fdb /app-editors
parentapp-editors/pluma-plugins: fix impossible dependency on gedit instead of pluma (diff)
downloadgentoo-9d938dc7549a99a9a266434a9f956d64a205778d.tar.gz
gentoo-9d938dc7549a99a9a266434a9f956d64a205778d.tar.bz2
gentoo-9d938dc7549a99a9a266434a9f956d64a205778d.zip
app-editors/pluma-plugins: fix configure failure to respect USE=python
There is a ./configure --enable-python but it was not passed. As a result it automagically detected python (and always succeeded since core distro tooling requires one). Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/pluma-plugins/pluma-plugins-1.26.0-r2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-editors/pluma-plugins/pluma-plugins-1.26.0-r2.ebuild b/app-editors/pluma-plugins/pluma-plugins-1.26.0-r2.ebuild
index bdfab472e753..0c6a11fbb5eb 100644
--- a/app-editors/pluma-plugins/pluma-plugins-1.26.0-r2.ebuild
+++ b/app-editors/pluma-plugins/pluma-plugins-1.26.0-r2.ebuild
@@ -65,6 +65,14 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
}
+src_configure() {
+ local myeconfargs=(
+ $(use_enable python)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
src_install() {
mate_src_install
use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"