summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-11-08 17:55:16 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-11-08 17:55:57 +0000
commitc8cfb66dca3c67f63fabe0870868ac94a47bba0f (patch)
treea29c7aeb234c1a19d79d75385414a34e956ba883 /app-editors
parentprofiles/arch/sparc: update mask for pkg needing gjs (diff)
downloadgentoo-c8cfb66dca3c67f63fabe0870868ac94a47bba0f.tar.gz
gentoo-c8cfb66dca3c67f63fabe0870868ac94a47bba0f.tar.bz2
gentoo-c8cfb66dca3c67f63fabe0870868ac94a47bba0f.zip
app-editors/vscode: add 1.95.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vscode/Manifest3
-rw-r--r--app-editors/vscode/vscode-1.95.2.ebuild131
2 files changed, 134 insertions, 0 deletions
diff --git a/app-editors/vscode/Manifest b/app-editors/vscode/Manifest
index 51f7e8bff19f..39f06af0bf3b 100644
--- a/app-editors/vscode/Manifest
+++ b/app-editors/vscode/Manifest
@@ -4,3 +4,6 @@ DIST vscode-1.94.2-arm64.tar.gz 141296756 BLAKE2B 160dbbeea65cd482c42e7d48c120c6
DIST vscode-1.95.1-amd64.tar.gz 148382845 BLAKE2B af91c360425684b660ab165bd5d10084d393be0ed84769c0b4967cc575aa62d1c6478410adb0aa3467e66dd40750ba068c026d3d37923997e93300ef773d76ed SHA512 c48f070031e239b5140028e0af05208a5519a844513b5ca99f779fb62cb56f03342df5809f0cfbf6fdd940ddbfb7176acf6f3ecf041f7484aa02de0457e1555c
DIST vscode-1.95.1-arm.tar.gz 132440825 BLAKE2B 99e79889dcb2d1131963a08258c6b1dc4519e08000dc707e0e19531fa015553efa7e49caeb7b813edaa59cf43186d979dff552bd0c2ff0559b09149666e66a15 SHA512 3e35c51b5127ce89743c465d4ffe61d8d5b6b52bea025cc09a55461289a1d8a22255a1f08151609177e7694c586cf918a0c562dd39051eb17aea02af60f33c87
DIST vscode-1.95.1-arm64.tar.gz 144398553 BLAKE2B 54d9bcba210df773a10361c79329d2d7511d942a5eead4af619ee84f6d159ed3b694cbb5f9d340e25fc4d39cb40de1e9c17894b16b63b265903260d03ef7e655 SHA512 aec996bc4071eba11d19d2a17dc92e127569d99e08fa0c2f9f66e4d8c62529457dbc65b21180442fd58197a5ad534a21eb287286fa3ac317171009733e6db86f
+DIST vscode-1.95.2-amd64.tar.gz 148406981 BLAKE2B cf76d73f3ea9d993cb25a2c69ddca39ea4b17754ed3eba1e778169f5471fcc57b4ebf79357f80f47aa8d58e0913587e9558f5fa95cf031ae1eddf7f702eac200 SHA512 f203f8f7e40d665d6eb77069473f10842e896776dfe3c0c8c502fa46798f524c8125d50020576e33ea3890b592d5ddf36d488039fbc75d0bd6d638304a8059ad
+DIST vscode-1.95.2-arm.tar.gz 132480370 BLAKE2B ef4f2c352be078a0941aba8fb84efb6795cd95ef9c2d14620fc1dfd4e7c97006618e100ab0434c380007b30b540cc58e3a65dc830e5faf8588fc0bdbc78f2610 SHA512 e1a3990bfbdbfac3b1ec7041e1e85307d39a1beb3bc42c79a23a9f07aa596fd41c8528b086702535fa862adadfe97397d4bd3c90fff3b3bcb1cddb1b78a61e8e
+DIST vscode-1.95.2-arm64.tar.gz 144419300 BLAKE2B 2f0720344a72b529e1dff6d413e9e715d47a6436610564911d584aad218998547f84672ac934effdcc211957c7d9c17acd8464d4c159a6b3451149d944127691 SHA512 c8680de5489b61542ca6d3d9a62b6a1c273ee4a5fcfbe7bb78e9da9fcee7668a908c72ec2081e1caf5dae539a884f3d9576ef91373c38a9e27d1c5b7c1b65d7e
diff --git a/app-editors/vscode/vscode-1.95.2.ebuild b/app-editors/vscode/vscode-1.95.2.ebuild
new file mode 100644
index 000000000000..7757235fed73
--- /dev/null
+++ b/app-editors/vscode/vscode-1.95.2.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="Multiplatform Visual Studio Code from Microsoft"
+HOMEPAGE="https://code.visualstudio.com"
+SRC_URI="
+ amd64? ( https://update.code.visualstudio.com/${PV}/linux-x64/stable -> ${P}-amd64.tar.gz )
+ arm? ( https://update.code.visualstudio.com/${PV}/linux-armhf/stable -> ${P}-arm.tar.gz )
+ arm64? ( https://update.code.visualstudio.com/${PV}/linux-arm64/stable -> ${P}-arm64.tar.gz )
+"
+S="${WORKDIR}"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ Microsoft-vscode
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* amd64 ~arm ~arm64"
+IUSE="egl kerberos wayland"
+RESTRICT="mirror strip bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+ kerberos? ( app-crypt/mit-krb5 )
+"
+
+QA_PREBUILT="*"
+
+src_install() {
+ if use amd64; then
+ cd "${WORKDIR}/VSCode-linux-x64" || die
+ elif use arm; then
+ cd "${WORKDIR}/VSCode-linux-armhf" || die
+ elif use arm64; then
+ cd "${WORKDIR}/VSCode-linux-arm64" || die
+ else
+ die "Visual Studio Code only supports amd64, arm and arm64"
+ fi
+
+ # Cleanup
+ rm -r ./resources/app/ThirdPartyNotices.txt || die
+
+ # Disable update server
+ sed -e "/updateUrl/d" -i ./resources/app/product.json || die
+
+ if ! use kerberos; then
+ rm -r ./resources/app/node_modules/kerberos || die
+ fi
+
+ # Install
+ pax-mark m code
+ mkdir -p "${ED}/opt/${PN}" || die
+ cp -r . "${ED}/opt/${PN}" || die
+ fperms 4711 /opt/${PN}/chrome-sandbox
+
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/vscode"
+ dosym -r "/opt/${PN}/bin/code" "usr/bin/code"
+
+ local EXEC_EXTRA_FLAGS=()
+ if use wayland; then
+ EXEC_EXTRA_FLAGS+=( "--ozone-platform-hint=auto" "--enable-wayland-ime" )
+ fi
+ if use egl; then
+ EXEC_EXTRA_FLAGS+=( "--use-gl=egl" )
+ fi
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code-url-handler.desktop" \
+ > "${T}/code-url-handler.desktop" || die
+
+ sed "s|@exec_extra_flags@|${EXEC_EXTRA_FLAGS[*]}|g" \
+ "${FILESDIR}/code.desktop" \
+ > "${T}/code.desktop" || die
+
+ domenu "${T}/code.desktop"
+ domenu "${T}/code-url-handler.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscode.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "desktop notifications" x11-libs/libnotify
+ optfeature "keyring support inside vscode" "virtual/secret-service"
+}