summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Frei <freijon@pm.me>2023-10-30 20:43:28 +0100
committerPatrick McLean <chutzpah@gentoo.org>2023-11-06 16:55:09 -0800
commitcc939b92f46d015c0ea25461ecb7789b3cde7078 (patch)
tree027fc302f7020427f4a03e460f1b1eb7b54aaaa7 /app-editors
parentsys-fs/unionfs-fuse: Drop old (diff)
downloadgentoo-cc939b92f46d015c0ea25461ecb7789b3cde7078.tar.gz
gentoo-cc939b92f46d015c0ea25461ecb7789b3cde7078.tar.bz2
gentoo-cc939b92f46d015c0ea25461ecb7789b3cde7078.zip
app-editors/helix: Added dev-vcs/git as BDEP and RDEP, minor opts
The reason is that the build will fail if 'git' is not found at build time. Also, the users can fetch/build the grammars at runtime and needs the 'git' binary for this feature. Minor optimizations: The 'shell-completion' eclass is now used. Also, a typo was fixed in 'pkg_postinst'. Closes: https://bugs.gentoo.org/916375 Signed-off-by: Jonas Frei <freijon@pm.me> Closes: https://github.com/gentoo/gentoo/pull/33586 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/helix/helix-23.10-r1.ebuild (renamed from app-editors/helix/helix-23.10.ebuild)15
1 files changed, 7 insertions, 8 deletions
diff --git a/app-editors/helix/helix-23.10.ebuild b/app-editors/helix/helix-23.10-r1.ebuild
index 26fba442bdd9..87c10936698d 100644
--- a/app-editors/helix/helix-23.10.ebuild
+++ b/app-editors/helix/helix-23.10-r1.ebuild
@@ -260,7 +260,7 @@ CRATES="
zerocopy@0.7.11
"
-inherit bash-completion-r1 cargo desktop xdg
+inherit cargo desktop shell-completion xdg
DESCRIPTION="A post-modern text editor"
HOMEPAGE="
@@ -279,6 +279,9 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="+grammar"
+BDEPEND="grammar? ( dev-vcs/git )"
+RDEPEND="dev-vcs/git"
+
QA_FLAGS_IGNORED="
usr/bin/hx
usr/share/helix/runtime/grammars/.*\.so
@@ -315,12 +318,8 @@ src_install() {
doins contrib/Helix.appdata.xml
newbashcomp contrib/completion/hx.bash hx
-
- insinto /usr/share/zsh/site-functions
- newins contrib/completion/hx.zsh _hx
-
- insinto /usr/share/fish/vendor_completions.d
- doins contrib/completion/hx.fish
+ newzshcomp contrib/completion/hx.zsh _hx
+ dofishcomp contrib/completion/hx.fish
newenvd - 99helix <<< 'HELIX_RUNTIME="/usr/share/helix/runtime"'
}
@@ -330,5 +329,5 @@ pkg_postinst() {
einfo "installed in '/usr/share/helix/runtime'. The environment variable"
einfo "HELIX_RUNTIME was also installed on your system. In running shell instances"
einfo "you need to run 'source /etc/profile' to pick up the new variable"
- einfo "or manually set the environment varialbe HELIX_RUNTIME=/usr/share/helix/runtime."
+ einfo "or manually set the environment variable HELIX_RUNTIME=/usr/share/helix/runtime."
}