summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-04 09:24:38 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-04 09:43:28 +0100
commit4669736c247a03b49b1f888a4dac87e2ce36e65c (patch)
tree78a406002a5c3d9055ac5bae33d478a2d04ce5bb /app-emacs/emms
parentapp-emacs/emms: drop old 15 (diff)
downloadgentoo-4669736c247a03b49b1f888a4dac87e2ce36e65c.tar.gz
gentoo-4669736c247a03b49b1f888a4dac87e2ce36e65c.tar.bz2
gentoo-4669736c247a03b49b1f888a4dac87e2ce36e65c.zip
app-emacs/emms: bump to 17
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/emms')
-rw-r--r--app-emacs/emms/Manifest1
-rw-r--r--app-emacs/emms/emms-17.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emacs/emms/Manifest b/app-emacs/emms/Manifest
index a58ddda29882..0de011f9e295 100644
--- a/app-emacs/emms/Manifest
+++ b/app-emacs/emms/Manifest
@@ -1 +1,2 @@
DIST emms-16.tar.gz 213445 BLAKE2B 982e10c1e3bf5f0e305f94d80a2d753f6220ac9a5b8c991ff58273c1d39cea932e51837c1238cd89b07795fb11156e5230e806fc1329f08d78d43ec06d61bbdd SHA512 d36c0d7f797442350266b3f3d2783b0ce1310f4ee86969e1dc20c21e5814b79f124db157898b28d62fcf68975f506d3bbf3792ee218ab87444b7555fcb6a6db2
+DIST emms-17.tar.gz 263213 BLAKE2B 0a72de7a59e2db9fb6a4fbfc78bc5417c0826d1719905063c0d037a424f73500e45de469850940ab3ce072b1c7a747bb65020a061d23a693706ba0894f7a441c SHA512 b8c6c2ee6e59214a6c2647b3ea4dac3a96ab6d5da7b0aa6890503621242ea7e56e91c27e4f8ccc20ed6def76ebd8be79633654067d39bfd9b2d5d831d31f2805
diff --git a/app-emacs/emms/emms-17.ebuild b/app-emacs/emms/emms-17.ebuild
new file mode 100644
index 000000000000..c5130396d32c
--- /dev/null
+++ b/app-emacs/emms/emms-17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="https://git.savannah.gnu.org/cgit/emms.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="media-libs/taglib"
+BDEPEND="${RDEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+DOCS=( AUTHORS NEWS README )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ exeinto /usr/bin
+ doexe src/emms-print-metadata
+
+ doinfo doc/emms.info*
+ doman emms-print-metadata.1
+
+ einstalldocs
+}