summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2018-04-08 21:25:21 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2018-04-08 21:25:46 +0200
commitfffe26e72fdc1d5ba88273ad244d0020434a5b9f (patch)
tree08c4a4b1483a9203d25756c18810bcf7847cc42c /app-emacs/slime/slime-2.20.ebuild
parentdev-libs/botan: cleanup (diff)
downloadgentoo-fffe26e72fdc1d5ba88273ad244d0020434a5b9f.tar.gz
gentoo-fffe26e72fdc1d5ba88273ad244d0020434a5b9f.tar.bz2
gentoo-fffe26e72fdc1d5ba88273ad244d0020434a5b9f.zip
app-emacs/slime: Fix doc build
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-emacs/slime/slime-2.20.ebuild')
-rw-r--r--app-emacs/slime/slime-2.20.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-emacs/slime/slime-2.20.ebuild b/app-emacs/slime/slime-2.20.ebuild
index b8a5bdb9d7fa..73d436c15fbb 100644
--- a/app-emacs/slime/slime-2.20.ebuild
+++ b/app-emacs/slime/slime-2.20.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit elisp eutils
+inherit elisp
DESCRIPTION="SLIME, the Superior Lisp Interaction Mode (Extended)"
HOMEPAGE="http://common-lisp.net/project/slime/"
@@ -25,22 +25,26 @@ CLPACKAGE=swank
CLSYSTEMS=swank
SITEFILE=70${PN}-gentoo.el
+PATCHES=(
+ # Should be fixed in >=app-emacs/slime-2.20
+ "${FILESDIR}/${PN}-2.20-fix-doc-build.patch"
+)
+
src_prepare() {
+ default
# Remove xref.lisp (which is non-free) unless USE flag is set
use xref || rm -f xref.lisp
- eapply_user
}
src_compile() {
elisp-compile *.el || die
BYTECOMPFLAGS="${BYTECOMPFLAGS} -L contrib -l slime" \
elisp-compile contrib/*.el lib/*.el || die
- emake -j1 -C doc slime.info || die "Cannot build info docs"
- #if use doc; then
- # VARTEXFONTS="${T}"/fonts \
- # emake -j1 -C doc slime.pdf || die "emake doc failed"
- #fi
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts \
+ emake -C doc all
+ fi
}
src_install() {