summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-28 17:12:15 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-28 17:13:14 +0200
commit1c4063b9ce0d4497d44307bafab471d3f0e2a5a6 (patch)
tree27b79a323b2df73b63f848ebf61bb2566efd24d5 /app-emacs/transient
parentapp-emacs/git-modes: add live version (diff)
downloadgentoo-1c4063b9ce0d4497d44307bafab471d3f0e2a5a6.tar.gz
gentoo-1c4063b9ce0d4497d44307bafab471d3f0e2a5a6.tar.bz2
gentoo-1c4063b9ce0d4497d44307bafab471d3f0e2a5a6.zip
app-emacs/transient: add live version
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/transient')
-rw-r--r--app-emacs/transient/transient-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/transient/transient-9999.ebuild b/app-emacs/transient/transient-9999.ebuild
new file mode 100644
index 000000000000..adb9d5ff1a85
--- /dev/null
+++ b/app-emacs/transient/transient-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Transient commands abstraction for GNU Emacs"
+HOMEPAGE="https://magit.vc/manual/transient/
+ https://github.com/magit/transient/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG README.org docs/${PN}.org )
+ELISP_TEXINFO="docs/${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND=">=app-emacs/compat-29.1.4.1"
+BDEPEND="
+ ${RDEPEND}
+ sys-apps/texinfo
+"
+
+src_prepare() {
+ mv lisp/*.el . || die
+
+ default
+}