summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-10-06 20:38:38 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-10-06 21:51:31 +0200
commitc2fdcdc7700242f3b9a835fe151d412a71a26e8f (patch)
tree7c6e9e03f2733f52c416276f13501dbba693b18d /app-emacs
parentapp-emacs/rg: minor tweaks (diff)
downloadgentoo-c2fdcdc7700242f3b9a835fe151d412a71a26e8f.tar.gz
gentoo-c2fdcdc7700242f3b9a835fe151d412a71a26e8f.tar.bz2
gentoo-c2fdcdc7700242f3b9a835fe151d412a71a26e8f.zip
app-emacs/parseedn: minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/parseedn/parseedn-1.2.1.ebuild33
1 files changed, 21 insertions, 12 deletions
diff --git a/app-emacs/parseedn/parseedn-1.2.1.ebuild b/app-emacs/parseedn/parseedn-1.2.1.ebuild
index 4d4b7b12cefa..1e7379362bd7 100644
--- a/app-emacs/parseedn/parseedn-1.2.1.ebuild
+++ b/app-emacs/parseedn/parseedn-1.2.1.ebuild
@@ -3,31 +3,40 @@
EAPI=8
-NEED_EMACS=26
+NEED_EMACS="26"
inherit elisp
DESCRIPTION="EDN parser for Emacs Lisp"
HOMEPAGE="https://github.com/clojure-emacs/parseedn/"
-SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/clojure-emacs/${PN}.git"
+else
+ SRC_URI="https://github.com/clojure-emacs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="GPL-3+"
-KEYWORDS="amd64 ~x86"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="app-emacs/parseclj"
+RDEPEND="
+ app-emacs/parseclj
+"
BDEPEND="
${RDEPEND}
- test? ( app-emacs/ert-runner )
"
-ELISP_REMOVE="test/${PN}-test.el" # Remove bad tests.
+# Remove bad tests.
+ELISP_REMOVE="
+ test/${PN}-test.el
+"
+
DOCS=( CHANGELOG.md README.md )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ert-runner -L . -L test --reporter ert+duration --script test || die
-}
+elisp-enable-tests ert-runner test