summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-04-16 15:37:06 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-04-16 15:37:06 +0100
commite8ba90674eb9321d64f79d341b7aede07c5a8bd5 (patch)
treead2593c00522e17243c02e7ff2705d1e67ab756a /app-emulation/aranym
parentapp-misc/scrub: keyword 2.6.1 for ~riscv (diff)
downloadgentoo-e8ba90674eb9321d64f79d341b7aede07c5a8bd5.tar.gz
gentoo-e8ba90674eb9321d64f79d341b7aede07c5a8bd5.tar.bz2
gentoo-e8ba90674eb9321d64f79d341b7aede07c5a8bd5.zip
app-emulation/aranym: Patch to fix musl build
Closes: https://bugs.gentoo.org/830437 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation/aranym')
-rw-r--r--app-emulation/aranym/aranym-1.1.0.ebuild1
-rw-r--r--app-emulation/aranym/files/aranym-1.1.0-libcwrap.patch24
2 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/aranym/aranym-1.1.0.ebuild b/app-emulation/aranym/aranym-1.1.0.ebuild
index fe2c0f728ab6..87efc9b39976 100644
--- a/app-emulation/aranym/aranym-1.1.0.ebuild
+++ b/app-emulation/aranym/aranym-1.1.0.ebuild
@@ -38,6 +38,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-1.1.0-conditional-installs.patch
+ "${FILESDIR}"/${PN}-1.1.0-libcwrap.patch
)
ECONF_SOURCE="${S}"
diff --git a/app-emulation/aranym/files/aranym-1.1.0-libcwrap.patch b/app-emulation/aranym/files/aranym-1.1.0-libcwrap.patch
new file mode 100644
index 000000000000..39ef32c7cc41
--- /dev/null
+++ b/app-emulation/aranym/files/aranym-1.1.0-libcwrap.patch
@@ -0,0 +1,24 @@
+From baa00c51d3cd63602912ee1b252fa774a43b042f Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sat, 16 Apr 2022 10:41:44 +0100
+Subject: [PATCH] Use libcwrap.h specifically with glibc, not just Linux, to
+ fix musl
+
+---
+ src/include/linux/libcwrap.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/include/linux/libcwrap.h b/src/include/linux/libcwrap.h
+index f68bafb1..9c5c6b8e 100644
+--- a/src/include/linux/libcwrap.h
++++ b/src/include/linux/libcwrap.h
+@@ -1,5 +1,5 @@
+ /* glibc bindings for target ABI version glibc 2.11 */
+-#if defined(__linux__) && !defined (__LIBC_CUSTOM_BINDINGS_H__) && !defined(__ANDROID__)
++#if defined(__GLIBC__) && defined(__linux__) && !defined (__LIBC_CUSTOM_BINDINGS_H__) && !defined(__ANDROID__)
+
+ #if defined (__cplusplus)
+ extern "C" {
+--
+2.34.1
+