summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-28 13:24:03 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-28 13:24:21 +0200
commit48dfb8af8c28bcb0af7e1435b938d206c136f2a2 (patch)
tree488b5a88b3535b460a87e5988a57ab5e2cc2e8f5 /app-emulation/containerd
parentapp-emulation/docker-runc: Update to a snapshot that is going to be used by d... (diff)
downloadgentoo-48dfb8af8c28bcb0af7e1435b938d206c136f2a2.tar.gz
gentoo-48dfb8af8c28bcb0af7e1435b938d206c136f2a2.tar.bz2
gentoo-48dfb8af8c28bcb0af7e1435b938d206c136f2a2.zip
app-emulation/containerd: Update to a snapshot that is going to be used by docker 17.06
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-emulation/containerd')
-rw-r--r--app-emulation/containerd/Manifest1
-rw-r--r--app-emulation/containerd/containerd-0.2.8_p20170504.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/containerd/Manifest b/app-emulation/containerd/Manifest
index 8b2946f50aa4..c818ccf0f8f8 100644
--- a/app-emulation/containerd/Manifest
+++ b/app-emulation/containerd/Manifest
@@ -3,3 +3,4 @@ DIST containerd-0.2.5_p20170308.tar.gz 1021631 SHA256 d08d3d0758b76f7de0e8f503b7
DIST containerd-0.2.6.tar.gz 1020572 SHA256 a67c4153ac5ae26b9d11daac133b90cba059ba16de7579e39c3e82bcda856493 SHA512 41018bda556a3ddfb1bd3a16e642548ba06f413b13fd1488e731896e277ba6c84a393ebd5de067ecaeccc695297a2b74edf22e5a3fe8f2e3eadf78d080bdeff6 WHIRLPOOL 98f64c888ea580074e51b91311ab186291cb2d3ecc9f178d828687dbb60b35104237041699b6125cf026edd245459a052fda1801ac3cd7e1efe34606c3d9a4eb
DIST containerd-0.2.7.tar.gz 1034541 SHA256 cc46de64a75fa8babe0a85aac987f926870bf84d78040430f95ce478ed195122 SHA512 d0885fa37aaa1110d9312f81102e619ca4ae8d3c39c83c01852fd8618945121596169a1d41017d19ad32ff47b619a2c1c18a3582d290a56f08640412dcfc451a WHIRLPOOL 35748adf2c097dad4c60e48b2eb3389b57e78fc8d3b228f15b0297b5c1d037a77f29118089a5159c1f25baf7e4d7f93f6fc74d3cd2c85164711378e2df6e251d
DIST containerd-0.2.8.tar.gz 1034518 SHA256 f002d4d93a86cd3a0c9e7d9d71455a94790302daab1e51dd2dd53e7f0ba4d217 SHA512 a8c0b9faa9bf225be315067aa634ee366c8d78a137dddade2ad09160ecd8f89d487fdce896efd73bedcd6d8c97e20f746ba949a13901c38977a40dbb558339d8 WHIRLPOOL 99058822f80d37e8a96968ae26cf00c33c8ed78fffeff9f2d07a2c25c76439ab44c92ce333712f6749787a04b65c54b112511d66c97cfcce35a5d5cf954ac2f4
+DIST containerd-0.2.8_p20170504.tar.gz 1231053 SHA256 6316ecefe43c89ddafd31608f6d21aeec250f498b27c194551bde3679e765865 SHA512 6b5fc4845c560239e197c93620f1b836972563f24c8a595ff82f6798c372c5b9a7a6be6dc52aa443d72b61108723d56a67884ff464f666085b3af28424e56136 WHIRLPOOL 2982a405aa82c28e7498e54d42d29557b6024ed411537c4b2084f8574111511f4e5cb751ac18b025919047aa45933bdd28171b871826f87cfa004d53503cfbb4
diff --git a/app-emulation/containerd/containerd-0.2.8_p20170504.ebuild b/app-emulation/containerd/containerd-0.2.8_p20170504.ebuild
new file mode 100644
index 000000000000..fd9cdbc70d56
--- /dev/null
+++ b/app-emulation/containerd/containerd-0.2.8_p20170504.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/${PN}/${PN}"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit golang-vcs
+else
+ MY_PV="${PV/_/-}"
+ EGIT_COMMIT="d24f39e203aa6be4944f06dd0fe38a618a36c764"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc64"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.tools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="hardened +seccomp"
+
+DEPEND=""
+RDEPEND=">=app-emulation/docker-runc-1.0.0_rc3_p20170607
+ seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_compile() {
+ local options=( $(usex seccomp "seccomp" '') )
+ export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+ LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}"
+}
+
+src_install() {
+ dobin bin/containerd* bin/ctr
+}