summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-12 23:54:18 +0100
committerSam James <sam@gentoo.org>2022-10-12 23:55:37 +0100
commitcd44a3d30d02e2bb500805121e06cb7dc36cddda (patch)
tree99acefeefd6f860f5c779704a19e598f5e7be000 /app-emulation/qemu-guest-agent
parentapp-emulation/qemu-guest-agent: Bump version to 7.1.0 (diff)
downloadgentoo-cd44a3d30d02e2bb500805121e06cb7dc36cddda.tar.gz
gentoo-cd44a3d30d02e2bb500805121e06cb7dc36cddda.tar.bz2
gentoo-cd44a3d30d02e2bb500805121e06cb7dc36cddda.zip
app-emulation/qemu-guest-agent: EAPI 8, modernise
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation/qemu-guest-agent')
-rw-r--r--app-emulation/qemu-guest-agent/qemu-guest-agent-7.1.0.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/app-emulation/qemu-guest-agent/qemu-guest-agent-7.1.0.ebuild b/app-emulation/qemu-guest-agent/qemu-guest-agent-7.1.0.ebuild
index 69eb43088388..1a76fe360988 100644
--- a/app-emulation/qemu-guest-agent/qemu-guest-agent-7.1.0.ebuild
+++ b/app-emulation/qemu-guest-agent/qemu-guest-agent-7.1.0.ebuild
@@ -1,29 +1,26 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
-inherit systemd toolchain-funcs udev python-any-r1
+inherit edo systemd toolchain-funcs python-any-r1 udev
MY_PN="qemu"
MY_P="${MY_PN}-${PV}"
-SRC_URI="http://wiki.qemu.org/download/${MY_P}.tar.xz"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-
DESCRIPTION="QEMU Guest Agent (qemu-ga) for use when running inside a VM"
HOMEPAGE="https://wiki.qemu.org/Features/GuestAgent"
+SRC_URI="http://wiki.qemu.org/download/${MY_P}.tar.xz"
LICENSE="GPL-2 BSD-2"
SLOT="0"
-IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
RDEPEND="dev-libs/glib"
-
-DEPEND="${RDEPEND}
- ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
S="${WORKDIR}/${MY_P}"
@@ -47,8 +44,8 @@ src_configure() {
--cxx="$(tc-getCXX)"
--host-cc="$(tc-getBUILD_CC)"
)
- echo "./configure ${myconf[*]}"
- ./configure "${myconf[@]}" || die
+
+ edo ./configure "${myconf[@]}"
}
src_install() {