summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-02 17:33:26 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-02 17:33:45 +0100
commitb9fbf27b66a5f2fc216e7bcdec230dc5c36b7b7d (patch)
treeaf5d509a196159fd7ff458c9524ed8f7161b4290 /app-emulation/virtualbox-modules
parentapp-emulation/virtualbox: Only place VRDPAuth.so with USE="pam". (diff)
downloadgentoo-b9fbf27b66a5f2fc216e7bcdec230dc5c36b7b7d.tar.gz
gentoo-b9fbf27b66a5f2fc216e7bcdec230dc5c36b7b7d.tar.bz2
gentoo-b9fbf27b66a5f2fc216e7bcdec230dc5c36b7b7d.zip
virtualbox packages: Removed old.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation/virtualbox-modules')
-rw-r--r--app-emulation/virtualbox-modules/Manifest1
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-5.1.26.ebuild64
2 files changed, 0 insertions, 65 deletions
diff --git a/app-emulation/virtualbox-modules/Manifest b/app-emulation/virtualbox-modules/Manifest
index cd5418fad2a3..c55f45ebe17b 100644
--- a/app-emulation/virtualbox-modules/Manifest
+++ b/app-emulation/virtualbox-modules/Manifest
@@ -1,4 +1,3 @@
-DIST vbox-kernel-module-src-5.1.26.tar.xz 625384 BLAKE2B f3f0676854e7c597281c4937e2753a117844f584248c824bce2f931adb3f1ee234b71b60f701da7043916fe716c3973ede0f39d6614c60a483fedf34cc70d49e SHA512 c77e0d8dfade2abac95162e7e7a424be4875e44d43bcf2a13e0e50caa69f5fd0d21c77f03bb2cd4cbd5df4ab31e9fbd49ecd9220a49af8cd10081b960e014010
DIST vbox-kernel-module-src-5.1.30.tar.xz 625424 BLAKE2B 00d33cad237af1f0d5b4dbea38f84e0327d10d97fc309a8c7536433cb4fddf3614e6de160646077040b4fdc6dd126cfa2250081084ca0243cc572d9f5e9d5dfd SHA512 8e2113584e63e2ace71b708dc77428fd09167a1bded12b47312a5a8f85ef448e17f76b4300dba4c8ec99d7f8cb278cef039c6282c676e35b8f200bafb5c4770a
DIST vbox-kernel-module-src-5.2.2.tar.xz 633924 BLAKE2B 85307332f3b0eaea1832b357c4f44a90c38165caaf3dae5d073a92f04f7d1ddf440e8a53fecf2dab4f0179002051382fa4fe1af8be12279bfc921f578c1743a1 SHA512 ec513912567bf58f367f08e212a5d3b82e7caae5fec6985f2253ee9405907b567c8cbd2dea277ddef1344711927eb75525f95d6204ef07cb1325d22185ccb5a4
DIST vbox-kernel-module-src-5.2.4.tar.xz 634212 BLAKE2B d8be416f958f672c2ab50b5197f708bc1febca292d5262eec710c07561be7de810fb1dfd5961ef9367c91e0ac1b6033419f85444471e8d40406d4ab860de2a23 SHA512 3c2113a8781cde1a44954267ee469db91c843305a5b1468b1fd346af3f3626a3d98c8a958ec0e255401f569f75e652dbbb1a85fd6cc6b203cf170745c630cee1
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-5.1.26.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-5.1.26.ebuild
deleted file mode 100644
index fc282ccbb370..000000000000
--- a/app-emulation/virtualbox-modules/virtualbox-modules-5.1.26.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# XXX: the tarball here is just the kernel modules split out of the binary
-# package that comes from virtualbox-bin
-
-EAPI=6
-
-inherit eutils linux-mod user
-
-MY_P=vbox-kernel-module-src-${PV}
-DESCRIPTION="Kernel Modules for Virtualbox"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="https://dev.gentoo.org/~polynomial-c/virtualbox/${MY_P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="pax_kernel"
-
-RDEPEND="!=app-emulation/virtualbox-9999"
-
-S=${WORKDIR}
-
-BUILD_TARGETS="all"
-BUILD_TARGET_ARCH="${ARCH}"
-MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S}) vboxpci(misc:${S})"
-
-pkg_setup() {
- enewgroup vboxusers
-
- CONFIG_CHECK="!TRIM_UNUSED_KSYMS"
- ERROR_TRIM_UNUSED_KSYMS="The kernel option CONFIG_TRIM_UNUSED_KSYMS removed kernel symbols that are needed by ${PN} to load correctly."
-
- linux-mod_pkg_setup
-
- BUILD_PARAMS="KERN_DIR=${KV_DIR} O=${KV_OUT_DIR} V=1 KBUILD_VERBOSE=1"
-}
-
-src_prepare() {
- if kernel_is -ge 2 6 33 ; then
- # evil patch for new kernels - header moved
- grep -lR linux/autoconf.h * | xargs sed -i -e 's:<linux/autoconf.h>:<generated/autoconf.h>:'
- fi
-
- if use pax_kernel && kernel_is -ge 3 0 0 ; then
- epatch "${FILESDIR}"/${PN}-4.1.4-pax-const.patch
- fi
-
- default
-}
-
-src_install() {
- linux-mod_src_install
- insinto /usr/lib/modules-load.d/
- doins "${FILESDIR}"/virtualbox.conf
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- elog "If you are using sys-apps/openrc, please add \"vboxdrv\", \"vboxnetflt\","
- elog "\"vboxnetadp\" and \"vboxpci\" to:"
- elog " /etc/conf.d/modules"
-}