summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-29 05:14:28 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-29 05:42:39 -0400
commit527d13170d519590c4fa3fd320d0c6a3bd5d88fc (patch)
treef57fd833c24a7221749c33c5210af2da69fcc1c6 /app-emulation/vkd3d-proton
parentapp-emulation/dxvk: update flags filters (diff)
downloadgentoo-527d13170d519590c4fa3fd320d0c6a3bd5d88fc.tar.gz
gentoo-527d13170d519590c4fa3fd320d0c6a3bd5d88fc.tar.bz2
gentoo-527d13170d519590c4fa3fd320d0c6a3bd5d88fc.zip
app-emulation/vkd3d-proton: update flags filters
* -fstack-clash-protection (bug #758914): ICE was fixed, if still run into this then updating gcc to a newer _p* snapshot should sort it (alternatively, use released >=gcc-13.1.0) * -fstack-protector* (bug #870136): mingw64-runtime-11.0.0 adds its own (partial) ssp support, allowing -D_FORTIFY_SOURCE=3 and -fstack-protector-strong without libssp. Using these to build Wine currently still leads to failure, but we can allow it here. Bug: https://bugs.gentoo.org/758914 Bug: https://bugs.gentoo.org/870136 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/vkd3d-proton')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild10
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild10
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.8_p20230207.ebuild8
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild10
4 files changed, 27 insertions, 11 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
index 8ff79bbbd1ba..2e3e5c86e2ce 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -103,10 +103,14 @@ src_configure() {
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
- filter-flags '-fstack-clash-protection' #758914
- filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+ if has_version '<dev-util/mingw64-toolchain-11' ||
+ { use crossdev-mingw &&
+ has_version "<cross-$(usex x86 i686 x86_64)-w64-mingw32/mingw64-runtime-11"; }
+ then
+ filter-flags '-fstack-protector*' #870136
+ fi
fi
CHOST_amd64=x86_64-w64-mingw32
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
index 633364ef6384..9acb9d5109a0 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,10 +108,14 @@ src_configure() {
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
- filter-flags '-fstack-clash-protection' #758914
- filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+ if has_version '<dev-util/mingw64-toolchain-11' ||
+ { use crossdev-mingw &&
+ has_version "<cross-$(usex x86 i686 x86_64)-w64-mingw32/mingw64-runtime-11"; }
+ then
+ filter-flags '-fstack-protector*' #870136
+ fi
fi
CHOST_amd64=x86_64-w64-mingw32
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.8_p20230207.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.8_p20230207.ebuild
index 58f1162cda67..0365c48985cf 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.8_p20230207.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.8_p20230207.ebuild
@@ -109,10 +109,14 @@ src_configure() {
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
- filter-flags '-fstack-clash-protection' #758914
- filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+ if has_version '<dev-util/mingw64-toolchain-11' ||
+ { use crossdev-mingw &&
+ has_version "<cross-$(usex x86 i686 x86_64)-w64-mingw32/mingw64-runtime-11"; }
+ then
+ filter-flags '-fstack-protector*' #870136
+ fi
fi
CHOST_amd64=x86_64-w64-mingw32
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
index 55490ce310fc..cb9a067747c6 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -108,10 +108,14 @@ src_configure() {
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL
- filter-flags '-fstack-clash-protection' #758914
- filter-flags '-fstack-protector*' #870136
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+ if has_version '<dev-util/mingw64-toolchain-11' ||
+ { use crossdev-mingw &&
+ has_version "<cross-$(usex x86 i686 x86_64)-w64-mingw32/mingw64-runtime-11"; }
+ then
+ filter-flags '-fstack-protector*' #870136
+ fi
fi
CHOST_amd64=x86_64-w64-mingw32