summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-06 03:34:47 +0000
committerSam James <sam@gentoo.org>2025-01-06 03:34:47 +0000
commit1cc20de7b3923bb562cde8f78302755095461f3d (patch)
tree020ac7cc5b647e10a1e97648978639c55ee89597 /app-emulation
parentapp-emulation/virt-manager: add 5.0.0-r1 with improvements (diff)
downloadgentoo-1cc20de7b3923bb562cde8f78302755095461f3d.tar.gz
gentoo-1cc20de7b3923bb562cde8f78302755095461f3d.tar.bz2
gentoo-1cc20de7b3923bb562cde8f78302755095461f3d.zip
app-emulation/virt-manager: sync live
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virt-manager/virt-manager-9999.ebuild65
1 files changed, 42 insertions, 23 deletions
diff --git a/app-emulation/virt-manager/virt-manager-9999.ebuild b/app-emulation/virt-manager/virt-manager-9999.ebuild
index f2095898d5d0..d9497668d4c6 100644
--- a/app-emulation/virt-manager/virt-manager-9999.ebuild
+++ b/app-emulation/virt-manager/virt-manager-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
-inherit gnome2 python-single-r1 optfeature meson
+inherit gnome2 python-single-r1 optfeature meson verify-sig
DESCRIPTION="A graphical tool for administering virtual machines"
HOMEPAGE="https://virt-manager.org https://github.com/virt-manager/virt-manager"
@@ -15,20 +15,24 @@ if [[ ${PV} == *9999* ]]; then
SRC_URI=""
inherit git-r3
else
- SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.xz"
+ SRC_URI="
+ https://releases.pagure.org/${PN}/${P}.tar.xz
+ verify-sig? ( https://releases.pagure.org/${PN}/${P}.tar.xz.asc )
+ "
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
-IUSE="gui policykit sasl"
+IUSE="gui policykit sasl verify-sig"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# https://github.com/virt-manager/virt-manager/blob/main/virt-manager.spec.in
RDEPEND="
${PYTHON_DEPS}
|| ( dev-libs/libisoburn app-cdr/cdrtools )
- >=app-emulation/libvirt-glib-1.0.0[introspection]
+ >=app-emulation/libvirt-glib-0.0.9[introspection]
>=sys-libs/libosinfo-0.2.10[introspection]
$(python_gen_cond_dep '
dev-libs/libxml2[python,${PYTHON_USEDEP}]
@@ -41,27 +45,40 @@ RDEPEND="
gnome-base/dconf
>=net-libs/gtk-vnc-0.3.8[gtk3(+),introspection]
net-misc/spice-gtk[usbredir,gtk3,introspection,sasl?]
- sys-apps/dbus[X]
+ sys-apps/dbus
x11-libs/gtk+:3[introspection]
- x11-libs/gtksourceview:4[introspection]
+ || (
+ x11-libs/gtksourceview:4[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ )
x11-libs/vte:2.91[introspection]
policykit? ( sys-auth/polkit[introspection] )
)
"
DEPEND="${RDEPEND}"
-BDEPEND="dev-python/docutils"
+BDEPEND="
+ dev-python/docutils
+ sys-devel/gettext
+ verify-sig? ( sec-keys/openpgp-keys-virt-manager )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/virt-manager.asc
-DOCS=( README.md NEWS.md )
+DOCS=( {DESIGN,NEWS,README}.md )
src_configure() {
- # While in the past we did allow test suite to run, any errors from
- # test_cli.py were ignored. Since that's where like 90% of tests actually
- # lives, just disable tests (and do not drag additional dependencies).
- local emesonargs=(
+ local emesonargs=( # in upstream's order
+ -Dupdate-icon-cache=false
-Dcompile-schemas=false
- -Ddefault-graphics=spice
+
+ # -Ddefault-graphics=spice # default
+ # we do not ship OpenVZ and bhyve does not work on linux
+ -Ddefault-hvs="['qemu','xen','lxc']"
+
+ # While in the past we did allow test suite to run, any errors from
+ # test_cli.py were ignored. Since that's where like 90% of tests actually
+ # lives, just disable tests (and do not drag additional dependencies).
-Dtests=disabled
- -Dupdate-icon-cache=false
)
meson_src_configure
@@ -70,12 +87,11 @@ src_configure() {
src_install() {
meson_src_install
- if ! use gui ; then
- rm -r "${ED}/usr/share/virt-manager/ui/" || die
- rm -r "${ED}/usr/share/virt-manager/icons/" || die
+ if ! use gui; then
+ rm -r "${ED}/usr/share/applications/${PN}.desktop" || die
+ rm -r "${ED}/usr/share/${PN}/{ui,icons}/" || die
rm -r "${ED}/usr/share/icons/" || die
- rm -r "${ED}/usr/share/applications/virt-manager.desktop" || die
- rm -r "${ED}/usr/bin/virt-manager" || die
+ rm -r "${ED}/usr/bin/${PN}" || die
fi
python_fix_shebang "${ED}"
@@ -84,6 +100,9 @@ src_install() {
pkg_postinst() {
use gui && gnome2_pkg_postinst
- optfeature "SSH_ASKPASS program implementation" lxqt-base/lxqt-openssh-askpass net-misc/ssh-askpass-fullscreen net-misc/x11-ssh-askpass
- optfeature "QEMU host support" app-emulation/qemu[usbredir,spice]
+ optfeature "Full QEMU host support" app-emulation/qemu[usbredir,spice]
+ optfeature "SSH_ASKPASS program implementation" lxqt-base/lxqt-openssh-askpass \
+ net-misc/ssh-askpass-fullscreen net-misc/x11-ssh-askpass
+ # it's possible this also requires libguestfs-appliance but it's a RDEPEND of libguestfs
+ optfeature "Inspection of guest filesystems" app-emulation/libguestfs[libvirt,python]
}