summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2025-01-02 17:31:51 +0100
committerConrad Kostecki <conikost@gentoo.org>2025-01-02 17:31:51 +0100
commit6b8aa28dc1b39d0c89eb8bf200d4917458dbfb41 (patch)
treefa9ecb0f14b3fed4275c3a6171a5bf34a0904713 /app-emulation
parentapp-emulation/faudio: drop 24.11 (diff)
downloadgentoo-6b8aa28dc1b39d0c89eb8bf200d4917458dbfb41.tar.gz
gentoo-6b8aa28dc1b39d0c89eb8bf200d4917458dbfb41.tar.bz2
gentoo-6b8aa28dc1b39d0c89eb8bf200d4917458dbfb41.zip
app-emulation/faudio: add 25.01
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/faudio/Manifest1
-rw-r--r--app-emulation/faudio/faudio-25.01.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/faudio/Manifest b/app-emulation/faudio/Manifest
index caf7729d7fea..3a3033e5a92f 100644
--- a/app-emulation/faudio/Manifest
+++ b/app-emulation/faudio/Manifest
@@ -1 +1,2 @@
DIST faudio-24.12.tar.gz 1126609 BLAKE2B 06b610a49080f036b521a0acbe10a82aae748e240dcb87cecf5eeda89d982e5fca3ae2d9a8afb2ad45957ddcb26f423ebbf2639b320e0fb2683aa0ab7cd0f523 SHA512 1bef0f3c60850537330033b136fbb5205901db8bfedcce7650b98564d8b514623f4b8e702adf025c9d6a8707eb7c73f90e9b8fd40085bd8027e1cb7c6f3be11e
+DIST faudio-25.01.tar.gz 1127223 BLAKE2B 93b82fd9cb5c0f0a5944568e6fc3e1ca4cc88c804e22da2c9a12f58922567fdfe9a01726cc69b91211c0853077eb071db8bc992f790b21c9138352ebd77f5cae SHA512 099292d41ace3ea85a9d8d465c4e55542cd5b233bf53d2088b97ec6c1f99c416dc09455efd328edf5e9c73dfa248bb48d0f08750c71f129fad3f93d5bc852ec7
diff --git a/app-emulation/faudio/faudio-25.01.ebuild b/app-emulation/faudio/faudio-25.01.ebuild
new file mode 100644
index 000000000000..dfce1c40eb5b
--- /dev/null
+++ b/app-emulation/faudio/faudio-25.01.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
+HOMEPAGE="https://fna-xna.github.io/"
+SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FAudio-${PV}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dumpvoices test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libsdl2[sound]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
+ use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION
+
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDUMP_VOICES=$(usex dumpvoices)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ einfo "Running faudio_tests, this may take some time without output..."
+ SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
+}