summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgerm <germtoo@outlook.com>2024-04-03 03:20:07 +0000
committerMatt Jolly <kangie@gentoo.org>2024-04-04 21:49:14 +1000
commitcc6414f1e4ef6a4652e1347d1cdfcfb74474ea40 (patch)
tree44e4b036c13ab235c38bc1fb0376e3ddd636c77e /app-emulation
parentsys-apps/hw-probe: keyword 1.6.5_p20230812 for ~loong (diff)
downloadgentoo-cc6414f1e4ef6a4652e1347d1cdfcfb74474ea40.tar.gz
gentoo-cc6414f1e4ef6a4652e1347d1cdfcfb74474ea40.tar.bz2
gentoo-cc6414f1e4ef6a4652e1347d1cdfcfb74474ea40.zip
app-emulation/faudio: add 23.10
Signed-off-by: germ <germtoo@outlook.com> Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/faudio/Manifest1
-rw-r--r--app-emulation/faudio/faudio-23.10.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emulation/faudio/Manifest b/app-emulation/faudio/Manifest
index dd95edd658a6..b51957207feb 100644
--- a/app-emulation/faudio/Manifest
+++ b/app-emulation/faudio/Manifest
@@ -1 +1,2 @@
DIST faudio-23.02.tar.gz 1111012 BLAKE2B c776a5b882697fbbed894f129165600b1aad8b303254e9ecbf6111fff71581491b484681a71d377854077dfc23b99d1217e5322bdd9923caf4471cc0bc2ca0f2 SHA512 d83adca1f1e42b1c7d63dad30886b58a914ac9a5a254f26d3fdb2386776840e3c40b22a8dd9c7172e6c97b0db989f919fd2ebeac2ec00075a8136ec9120bc390
+DIST faudio-23.10.tar.gz 1120033 BLAKE2B 2f064ba71386db69870b4e523625c421b2062f3584f834b55367dd675a1a61509831b036ed2e459cd2ea247e2b56401142bf73b6e828bd2ff4699623ba0d453f SHA512 cc17c1c3950267a8cc69d0a263deef1d80e8bb9f658f1c2cd1c137bccac1d2be234d17f9b790bbe8bd1ba9da7e13676d3d38e328399d5a706f6ed502365de9ba
diff --git a/app-emulation/faudio/faudio-23.10.ebuild b/app-emulation/faudio/faudio-23.10.ebuild
new file mode 100644
index 000000000000..e372ae484496
--- /dev/null
+++ b/app-emulation/faudio/faudio-23.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Accuracy-focused XAudio reimplementation for open platforms"
+HOMEPAGE="https://fna-xna.github.io/"
+SRC_URI="https://github.com/FNA-XNA/FAudio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FAudio-${PV}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug dumpvoices test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/libsdl2[sound]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ append-cppflags -D_DEFAULT_SOURCE # usleep() in tests
+ use debug || append-cppflags -DFAUDIO_DISABLE_DEBUGCONFIGURATION
+
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ -DDUMP_VOICES=$(usex dumpvoices)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ einfo "Running faudio_tests, this may take some time without output..."
+ SDL_AUDIODRIVER=dummy "${BUILD_DIR}"/faudio_tests || die
+}