summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-09-25 08:19:46 -0400
committerSam James <sam@gentoo.org>2024-09-26 07:13:25 +0100
commitee6fb718f41c559c7bc00b531894e2849837ee6a (patch)
tree7aba809cc1bf27a1dc17599e20b79b2d18d78496 /app-emulation
parentapp-emulation/qemu: Add xdp USE flag (diff)
downloadgentoo-ee6fb718f41c559c7bc00b531894e2849837ee6a.tar.gz
gentoo-ee6fb718f41c559c7bc00b531894e2849837ee6a.tar.bz2
gentoo-ee6fb718f41c559c7bc00b531894e2849837ee6a.zip
app-emulation/qemu: Add xdp USE flag to live ebuild
This will add an xdp USE flag to fix situations where users have the bpf USE flag disabled but libxdp is installed thru net-libs/xdp-tools. This results in QEMU automatically detecting this and attempting to build af-xdp and failing. Credit-to: holgerh, parona Bug: https://bugs.gentoo.org/920459 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/35197 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 978471403537..c959ff18faaf 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -66,7 +66,7 @@ IUSE="accessibility +aio alsa bpf bzip2 capstone +curl debug ${QEMU_DOC_USEFLAG}
plugins +png pulseaudio python rbd sasl +seccomp sdl sdl-image selinux
+slirp
smartcard snappy spice ssh static-user systemtap test udev usb
- usbredir vde +vhost-net virgl virtfs +vnc vte xattr xen
+ usbredir vde +vhost-net virgl virtfs +vnc vte xattr xdp xen
zstd"
COMMON_TARGETS="
@@ -141,6 +141,7 @@ REQUIRED_USE="
vte? ( gtk )
multipath? ( udev )
plugins? ( !static-user )
+ xdp? ( bpf )
"
for smname in ${IUSE_SOFTMMU_TARGETS} ; do
REQUIRED_USE+=" qemu_softmmu_targets_${smname}? ( kernel_linux? ( seccomp ) )"
@@ -235,6 +236,7 @@ SOFTMMU_TOOLS_DEPEND="
vde? ( net-misc/vde[static-libs(+)] )
virgl? ( media-libs/virglrenderer[static-libs(+)] )
virtfs? ( sys-libs/libcap )
+ xdp? ( net-libs/xdp-tools )
xen? ( app-emulation/xen-tools:= )
zstd? ( >=app-arch/zstd-1.4.0[static-libs(+)] )
"
@@ -633,6 +635,7 @@ qemu_src_configure() {
$(conf_softmmu virtfs)
$(conf_notuser vnc)
$(conf_notuser vte)
+ $(conf_softmmu xdp af-xdp)
$(conf_notuser xen)
$(conf_notuser xen xen-pci-passthrough)
# use prebuilt keymaps, bug #759604