summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-07-01 14:18:12 +0200
committerSam James <sam@gentoo.org>2022-07-03 00:39:34 +0100
commite85524925605d5a95b2d40a5e7ec05d793b0b57e (patch)
tree230e65891dfaab05f0a8b1a4648e2b3b4391b30d /app-forensics/yara
parentsci-biology/trnascan-se: update EAPI 6 -> 8 (diff)
downloadgentoo-e85524925605d5a95b2d40a5e7ec05d793b0b57e.tar.gz
gentoo-e85524925605d5a95b2d40a5e7ec05d793b0b57e.tar.bz2
gentoo-e85524925605d5a95b2d40a5e7ec05d793b0b57e.zip
app-forensics/yara: version bump 4.2.2
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/26187 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-forensics/yara')
-rw-r--r--app-forensics/yara/Manifest1
-rw-r--r--app-forensics/yara/yara-4.2.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 9f554729d3ff..b121a9780e37 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,2 +1,3 @@
DIST yara-4.2.0.tar.gz 1284059 BLAKE2B 735d161fde5f84199315f1ce6d31f1ad79488312bede85d2941a03cb97fe75c3c4db0b3cba75782d338a462d87e9d9ed57b393bbdb68decfb350a1bbd096258b SHA512 24ca707015c77d87126bcaac0991997f6b09403024765d615a06db47191a3f0177e1c1eb4a917ec8412876b61d28f4a708f36999ddd9214c3967968c71ae3b7c
DIST yara-4.2.1.tar.gz 1285173 BLAKE2B dc290bf7fe85d468fd519e68a12d88097d817ca064a665397ba64768078a2d572b46e488eb48747ea1904207598b41a72a510b4b8e4e8601cf518cb6ab98c322 SHA512 036a35d713647b23998135da0d27c13a8876aa44e18e3c9dc99fa425273d7c4a953cbdc78f413f29e8bf818d84b340d0719e241d2a83b7165a16d97e952c45b0
+DIST yara-4.2.2.tar.gz 1287486 BLAKE2B 956a9ed4dab64d24cff680248b4f95b06287e96d27b3f94ff80e97641b3dc4581eaee59cf0d19dfffa9f90a6f0a56f95d3f90f9e9472b65e133bf4aac3e42da3 SHA512 6eb42e63eff93ce636e1d2ae84e30621eeea0d91e1d72bb2cbe826aca6af306bb3564ac2314bc090fb59c9aca5436e72d33658009722ce0cfbaae7ef87cc894e
diff --git a/app-forensics/yara/yara-4.2.2.ebuild b/app-forensics/yara/yara-4.2.2.ebuild
new file mode 100644
index 000000000000..55e7f11069d5
--- /dev/null
+++ b/app-forensics/yara/yara-4.2.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="http://virustotal.github.io/yara/"
+SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+LICENSE="Apache-2.0"
+SLOT="0/8"
+if [[ ${PV} != *_rc* ]] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-test.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" -name '*.a' -o -name '*.la' -delete || die
+}