summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGraham Ramsey <graham.ramsey@gmail.com>2023-05-13 16:52:39 +0100
committerSam James <sam@gentoo.org>2023-05-15 06:38:36 +0100
commitc75a5f92e13ed94df95a430b5735df8b68469486 (patch)
treeb1ef5bbf99352e93ea2dec7cccc789ee9e7861c1 /app-i18n
parentapp-i18n/libpinyin: add 2.8.1 (diff)
downloadgentoo-c75a5f92e13ed94df95a430b5735df8b68469486.tar.gz
gentoo-c75a5f92e13ed94df95a430b5735df8b68469486.tar.bz2
gentoo-c75a5f92e13ed94df95a430b5735df8b68469486.zip
app-i18n/ibus-libpinyin: add 1.15.2
Bug: https://bugs.gentoo.org/898402 Signed-off-by: Graham Ramsey <graham.ramsey@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus-libpinyin/Manifest1
-rw-r--r--app-i18n/ibus-libpinyin/ibus-libpinyin-1.15.2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-i18n/ibus-libpinyin/Manifest b/app-i18n/ibus-libpinyin/Manifest
index d8cf91f8963c..373863321eaa 100644
--- a/app-i18n/ibus-libpinyin/Manifest
+++ b/app-i18n/ibus-libpinyin/Manifest
@@ -1 +1,2 @@
DIST ibus-libpinyin-1.13.1.tar.gz 1726900 BLAKE2B 2540b5ca6657fe421f6f2986f32fba1b8840cafcc37b3ec5402705cb0edc0aac6b12d972b5da0326339a04c875dbd8f8cce902f613558f3f9d21b4a0cace31a3 SHA512 ee3a8c95e091992acb0558ff297743eb49bd8c73fbb9cd1f2b56db75137573dda2c677b1b25eb213fbd8779be004b06f95cded04273d7a469cf49f45cc27813a
+DIST ibus-libpinyin-1.15.2.tar.gz 1728300 BLAKE2B a7699fe7f4d7360d09b8c311919630c87fcf2250929f42be2adf1b29a16e60bef2df46539e0fb75ee27700ec7262eb175e6a4d56bedeb895a6272e097a636d00 SHA512 be7525221c4a95df885d1c8c60716c32ad0cfa0a13ca5f9034d06efebf18ab1c207383b30c017da28c1078724b4d9943fc82def68c94bb4e2a0a1e6273c7ad7f
diff --git a/app-i18n/ibus-libpinyin/ibus-libpinyin-1.15.2.ebuild b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.15.2.ebuild
new file mode 100644
index 000000000000..e5bd26774532
--- /dev/null
+++ b/app-i18n/ibus-libpinyin/ibus-libpinyin-1.15.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2015-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+LUA_COMPAT=( lua5-{1..3} )
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools gnome2-utils lua-single python-single-r1
+
+DESCRIPTION="Intelligent Pinyin and Bopomofo input methods based on LibPinyin for IBus"
+HOMEPAGE="https://github.com/libpinyin/ibus-libpinyin https://sourceforge.net/projects/libpinyin/"
+SRC_URI="https://github.com/libpinyin/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost lua opencc"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ lua? ( ${LUA_REQUIRED_USE} )"
+
+BDEPEND="dev-db/sqlite:3
+ virtual/pkgconfig"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-i18n/libpinyin-2.2.1:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ virtual/libintl
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ boost? ( dev-libs/boost:= )
+ lua? ( ${LUA_DEPS} )
+ opencc? ( app-i18n/opencc:= )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ if use lua; then
+ lua-single_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^appdatadir/s:/appdata:/metainfo:" \
+ data/Makefile.am || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-english-input-mode \
+ $(use_enable boost) \
+ $(use_enable lua lua-extension) \
+ $(use_enable opencc)
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}