summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-08-01 22:50:11 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-08-01 23:23:12 +0900
commitdbbd730dd7b0737f667a0488176eba9780014dfb (patch)
tree6120018794bb9573635f7aa32e7c81e9d91778a1 /app-i18n
parentapp-i18n/ibus: drop old (diff)
downloadgentoo-dbbd730dd7b0737f667a0488176eba9780014dfb.tar.gz
gentoo-dbbd730dd7b0737f667a0488176eba9780014dfb.tar.bz2
gentoo-dbbd730dd7b0737f667a0488176eba9780014dfb.zip
app-i18n/ibus: update to EAPI 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus/ibus-1.5.12.ebuild155
-rw-r--r--app-i18n/ibus/ibus-1.5.15.ebuild157
-rw-r--r--app-i18n/ibus/metadata.xml12
3 files changed, 117 insertions, 207 deletions
diff --git a/app-i18n/ibus/ibus-1.5.12.ebuild b/app-i18n/ibus/ibus-1.5.12.ebuild
index 2cfa0156fa24..12aa72a0cdd0 100644
--- a/app-i18n/ibus/ibus-1.5.12.ebuild
+++ b/app-i18n/ibus/ibus-1.5.12.ebuild
@@ -1,188 +1,143 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
+EAPI="6"
PYTHON_COMPAT=( python2_7 )
VALA_USE_DEPEND="vapigen"
-# Vapigen is needed for the vala binding
-# Valac is needed when building from git for the engine
-UPSTREAM_VER=
-inherit autotools bash-completion-r1 eutils gnome2-utils multilib python-single-r1 readme.gentoo-r1 vala virtualx
+inherit autotools bash-completion-r1 gnome2-utils ltprune python-single-r1 vala virtualx
DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="deprecated gconf gtk +gtk3 +introspection nls +python test vala wayland +X"
-REQUIRED_USE="
- || ( gtk gtk3 X )
+RESTRICT="test"
+REQUIRED_USE="|| ( gtk gtk3 X )
deprecated? ( python )
vala? ( introspection )
python? (
${PYTHON_REQUIRED_USE}
|| ( deprecated ( gtk3 introspection ) ) )" #342903
-[[ -n ${UPSTREAM_VER} ]] && \
- UPSTRAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
-
-SRC_URI="https://github.com/ibus/ibus/releases/download/${PV}/${P}.tar.gz
- ${UPSTRAM_PATCHSET_URI}"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.26:2
+CDEPEND="app-text/iso-codes
+ dev-libs/glib:2
+ gnome-base/dconf
gnome-base/librsvg:2
sys-apps/dbus[X?]
- app-text/iso-codes
- >=gnome-base/dconf-0.13.4
x11-libs/libnotify
- gconf? ( >=gnome-base/gconf-2.12:2 )
+ gconf? ( gnome-base/gconf:2 )
gtk? ( x11-libs/gtk+:2 )
gtk3? ( x11-libs/gtk+:3 )
- python? ( ${PYTHON_DEPS} )
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
X? (
+ || (
+ x11-libs/gtk+:3
+ x11-libs/gtk+:2
+ )
x11-libs/libX11
- x11-libs/gtk+:2 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.8 )
- nls? ( virtual/libintl )
- wayland? ( dev-libs/wayland )"
-RDEPEND="${COMMON_DEPEND}
- x11-apps/setxkbmap
+ )"
+RDEPEND="${CDEPEND}
python? (
- dev-python/pyxdg
deprecated? (
- >=dev-python/dbus-python-0.83
- dev-python/pygobject:2
- dev-python/pygtk:2 )
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )
gtk3? (
- dev-python/pygobject:3
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/pango[introspection]
- x11-libs/gtk+:3[introspection] )
+ x11-libs/gtk+:3[introspection]
+ )
)"
-DEPEND="${COMMON_DEPEND}
- >=dev-lang/perl-5.8.1
- dev-util/gtk-doc-am
+DEPEND="${CDEPEND}
dev-util/intltool
virtual/pkgconfig
- nls? ( >=sys-devel/gettext-0.16.1 )
+ nls? ( sys-devel/gettext )
vala? ( $(vala_depend) )"
-# stress test in bus/ fails
-# IBUS-CRITICAL **: bus_test_client_init: assertion `ibus_bus_is_connected (_bus)' failed
-RESTRICT="test"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="To use ibus, you should:
-1. Get input engines from sunrise overlay.
-Run \"emerge -s ibus-\" in your favorite terminal
-for a list of packages we already have.
-
-2. Setup ibus:
-$ ibus-setup
-
-3. Set the following in your user startup scripts
-such as .xinitrc, .xsession or .xprofile:
-
-export XMODIFIERS=\"@im=ibus\"
-export GTK_IM_MODULE=\"ibus\"
-export QT_IM_MODULE=\"xim\"
-ibus-daemon -d -x
-"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
src_prepare() {
- # Upstream's patchset
- if [[ -n ${UPSTREAM_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-upstream
- fi
-
- # We run "dconf update" in pkg_postinst/postrm to avoid sandbox violations
- sed -e 's/dconf update/:/' \
- -i data/dconf/Makefile.{am,in} || die
use vala && vala_src_prepare
+ sed -i "/^bash_completion/d" tools/Makefile.am
+
+ default
eautoreconf
}
src_configure() {
- local python_conf
+ local python_conf=()
if use python; then
- python_conf="PYTHON=${PYTHON}
+ python_conf+=(
$(use_enable deprecated python-library)
- $(use_enable gtk3 setup)"
+ $(use_enable gtk3 setup)
+ --with-python=${EPYTHON}
+ )
else
- python_conf="--disable-python-library --disable-setup"
+ python_conf+=( --disable-setup )
fi
+
econf \
- --enable-dconf \
- $(use_enable introspection) \
$(use_enable gconf) \
$(use_enable gtk gtk2) \
- $(use_enable gtk xim) \
- $(use_enable gtk3) \
$(use_enable gtk3 ui) \
+ $(use_enable gtk3) \
+ $(use_enable introspection) \
$(use_enable nls) \
$(use_enable test tests) \
- $(use_enable X xim) \
$(use_enable vala) \
$(use_enable wayland) \
- ${python_conf}
+ $(use_enable X xim) \
+ "${python_conf[@]}"
}
src_test() {
unset DBUS_SESSION_BUS_ADDRESS
- Xemake check || die
+ virtx emake -j1 check
}
src_install() {
default
+ prune_libtool_files --modules
- prune_libtool_files --all
+ keepdir /usr/share/ibus/engine
- mv "${ED}"/usr/share/bash-completion/completions/ibus.bash "${T}"
- rm -rf "${ED}"/usr/share/bash-completion || die
- newbashcomp "${T}"/ibus.bash ${PN}
- insinto /etc/X11/xinit/xinput.d
- newins xinput-ibus ibus.conf
+ newbashcomp tools/${PN}.bash ${PN}
- keepdir /usr/share/ibus/{engine,icons} #289547
-
- use deprecated && python_optimize
- use python && use gtk3 && python_optimize
-
- readme.gentoo_create_doc
+ insinto /etc/X11/xinit/xinput.d
+ newins xinput-${PN} ${PN}.conf
}
pkg_preinst() {
use gconf && gnome2_gconf_savelist
- gnome2_schemas_savelist
gnome2_icon_savelist
+ gnome2_schemas_savelist
}
pkg_postinst() {
use gconf && gnome2_gconf_install
use gtk && gnome2_query_immodules_gtk2
use gtk3 && gnome2_query_immodules_gtk3
- gnome2_schemas_update
gnome2_icon_cache_update
- readme.gentoo_print_elog
+ gnome2_schemas_update
}
pkg_postrm() {
use gtk && gnome2_query_immodules_gtk2
use gtk3 && gnome2_query_immodules_gtk3
- use gconf && gnome2_schemas_update
gnome2_icon_cache_update
+ gnome2_schemas_update
}
diff --git a/app-i18n/ibus/ibus-1.5.15.ebuild b/app-i18n/ibus/ibus-1.5.15.ebuild
index 33b9e5be6dca..8900ff31aaeb 100644
--- a/app-i18n/ibus/ibus-1.5.15.ebuild
+++ b/app-i18n/ibus/ibus-1.5.15.ebuild
@@ -1,189 +1,144 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
+EAPI="6"
PYTHON_COMPAT=( python2_7 )
VALA_USE_DEPEND="vapigen"
-# Vapigen is needed for the vala binding
-# Valac is needed when building from git for the engine
-UPSTREAM_VER=
-inherit autotools bash-completion-r1 eutils gnome2-utils multilib python-single-r1 readme.gentoo-r1 vala virtualx
+inherit autotools bash-completion-r1 gnome2-utils ltprune python-single-r1 vala virtualx
DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
HOMEPAGE="https://github.com/ibus/ibus/wiki"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="deprecated gconf gtk +gtk3 +introspection nls +python test vala wayland +X"
-REQUIRED_USE="
- || ( gtk gtk3 X )
+RESTRICT="test"
+REQUIRED_USE="|| ( gtk gtk3 X )
deprecated? ( python )
vala? ( introspection )
python? (
${PYTHON_REQUIRED_USE}
|| ( deprecated ( gtk3 introspection ) ) )" #342903
-[[ -n ${UPSTREAM_VER} ]] && \
- UPSTRAM_PATCHSET_URI="http://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
-
-SRC_URI="https://github.com/ibus/ibus/releases/download/${PV}/${P}.tar.gz
- ${UPSTRAM_PATCHSET_URI}"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.26:2
+CDEPEND="app-text/iso-codes
+ dev-libs/glib:2
+ gnome-base/dconf
gnome-base/librsvg:2
sys-apps/dbus[X?]
- app-text/iso-codes
- >=gnome-base/dconf-0.13.4
x11-libs/libnotify
- gconf? ( >=gnome-base/gconf-2.12:2 )
+ gconf? ( gnome-base/gconf:2 )
gtk? ( x11-libs/gtk+:2 )
gtk3? ( x11-libs/gtk+:3 )
- python? ( ${PYTHON_DEPS} )
+ introspection? ( dev-libs/gobject-introspection )
+ nls? ( virtual/libintl )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+ wayland? (
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ )
X? (
+ || (
+ x11-libs/gtk+:3
+ x11-libs/gtk+:2
+ )
x11-libs/libX11
- x11-libs/gtk+:2 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.8 )
- nls? ( virtual/libintl )
- wayland? ( dev-libs/wayland )"
-RDEPEND="${COMMON_DEPEND}
- x11-apps/setxkbmap
+ )"
+RDEPEND="${CDEPEND}
python? (
- dev-python/pyxdg
deprecated? (
- >=dev-python/dbus-python-0.83
- dev-python/pygobject:2
- dev-python/pygtk:2 )
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )
gtk3? (
- dev-python/pygobject:3
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/pango[introspection]
- x11-libs/gtk+:3[introspection] )
+ x11-libs/gtk+:3[introspection]
+ )
)"
-DEPEND="${COMMON_DEPEND}
- >=dev-lang/perl-5.8.1
- dev-util/gtk-doc-am
+DEPEND="${CDEPEND}
dev-util/intltool
virtual/pkgconfig
- nls? ( >=sys-devel/gettext-0.16.1 )
+ nls? ( sys-devel/gettext )
vala? ( $(vala_depend) )"
-# stress test in bus/ fails
-# IBUS-CRITICAL **: bus_test_client_init: assertion `ibus_bus_is_connected (_bus)' failed
-RESTRICT="test"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-DISABLE_AUTOFORMATTING="yes"
-DOC_CONTENTS="To use ibus, you should:
-1. Get input engines from sunrise overlay.
-Run \"emerge -s ibus-\" in your favorite terminal
-for a list of packages we already have.
-
-2. Setup ibus:
-$ ibus-setup
-
-3. Set the following in your user startup scripts
-such as .xinitrc, .xsession or .xprofile:
-
-export XMODIFIERS=\"@im=ibus\"
-export GTK_IM_MODULE=\"ibus\"
-export QT_IM_MODULE=\"xim\"
-ibus-daemon -d -x
-"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
src_prepare() {
- # Upstream's patchset
- if [[ -n ${UPSTREAM_VER} ]]; then
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_OPTS="-p1" \
- epatch "${WORKDIR}"/patches-upstream
- fi
-
- # We run "dconf update" in pkg_postinst/postrm to avoid sandbox violations
- sed -e 's/dconf update/:/' \
- -i data/dconf/Makefile.{am,in} || die
use vala && vala_src_prepare
+ sed -i "/^bash_completion/d" tools/Makefile.am
+
+ default
eautoreconf
}
src_configure() {
- local python_conf
+ local python_conf=()
if use python; then
- python_conf="PYTHON=${PYTHON}
+ python_conf+=(
$(use_enable deprecated python-library)
- $(use_enable gtk3 setup)"
+ $(use_enable gtk3 setup)
+ --with-python=${EPYTHON}
+ )
else
- python_conf="--disable-python-library --disable-setup"
+ python_conf+=( --disable-setup )
fi
+
econf \
- --enable-dconf \
- --disable-emoji-dict \
- $(use_enable introspection) \
$(use_enable gconf) \
$(use_enable gtk gtk2) \
- $(use_enable gtk xim) \
- $(use_enable gtk3) \
$(use_enable gtk3 ui) \
+ $(use_enable gtk3) \
+ $(use_enable introspection) \
$(use_enable nls) \
$(use_enable test tests) \
- $(use_enable X xim) \
$(use_enable vala) \
$(use_enable wayland) \
- ${python_conf}
+ $(use_enable X xim) \
+ --disable-emoji-dict \
+ "${python_conf[@]}"
}
src_test() {
unset DBUS_SESSION_BUS_ADDRESS
- Xemake check || die
+ virtx emake -j1 check
}
src_install() {
default
+ prune_libtool_files --modules
- prune_libtool_files --all
+ keepdir /usr/share/ibus/engine
- mv "${ED}"/usr/share/bash-completion/completions/ibus.bash "${T}"
- rm -rf "${ED}"/usr/share/bash-completion || die
- newbashcomp "${T}"/ibus.bash ${PN}
- insinto /etc/X11/xinit/xinput.d
- newins xinput-ibus ibus.conf
-
- keepdir /usr/share/ibus/{engine,icons} #289547
-
- use deprecated && python_optimize
- use python && use gtk3 && python_optimize
+ newbashcomp tools/${PN}.bash ${PN}
- readme.gentoo_create_doc
+ insinto /etc/X11/xinit/xinput.d
+ newins xinput-${PN} ${PN}.conf
}
pkg_preinst() {
use gconf && gnome2_gconf_savelist
- gnome2_schemas_savelist
gnome2_icon_savelist
+ gnome2_schemas_savelist
}
pkg_postinst() {
use gconf && gnome2_gconf_install
use gtk && gnome2_query_immodules_gtk2
use gtk3 && gnome2_query_immodules_gtk3
- gnome2_schemas_update
gnome2_icon_cache_update
- readme.gentoo_print_elog
+ gnome2_schemas_update
}
pkg_postrm() {
use gtk && gnome2_query_immodules_gtk2
use gtk3 && gnome2_query_immodules_gtk3
- use gconf && gnome2_schemas_update
gnome2_icon_cache_update
+ gnome2_schemas_update
}
diff --git a/app-i18n/ibus/metadata.xml b/app-i18n/ibus/metadata.xml
index f67071b7101d..9fc8f486d7d7 100644
--- a/app-i18n/ibus/metadata.xml
+++ b/app-i18n/ibus/metadata.xml
@@ -6,14 +6,14 @@
<name>Cjk</name>
</maintainer>
<longdescription lang="en">
-IBus means Intelligent Input Bus. It is a new input framework for Linux OS. It provides
-full featured and user friendly input method user interface. It also may help
-developers to develop input method easily.
-</longdescription>
+ IBus is a Intelligent Input Bus. It is a new input framework for Linux OS.
+ It provides full featured and user friendly input method user interface. It
+ also may help developers to develop input method easily.
+ </longdescription>
<use>
+ <flag name="deprecated">Install the deprecated iBus Python library</flag>
<flag name="gconf">Enable support for <pkg>gnome-base/gconf</pkg></flag>
- <flag name="gtk3">Enable support for gtk+3</flag>
- <flag name="deprecated">install the deprecated ibus python library</flag>
+ <flag name="gtk3">Enable support for <pkg>x11-libs/gtk+</pkg>:3</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:ibus_project:ibus</remote-id>