summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-18 04:26:18 +0100
committerSam James <sam@gentoo.org>2023-04-18 04:26:18 +0100
commitfab3e6588af0894f13fcffb7af177fbe4de7f0f4 (patch)
treef1979bfc96fea4d9b6973950485746603038b527 /app-misc/tmux-mem-cpu-load
parentdev-db/redis: add 6.2.12 (diff)
downloadgentoo-fab3e6588af0894f13fcffb7af177fbe4de7f0f4.tar.gz
gentoo-fab3e6588af0894f13fcffb7af177fbe4de7f0f4.tar.bz2
gentoo-fab3e6588af0894f13fcffb7af177fbe4de7f0f4.zip
app-misc/tmux-mem-cpu-load: add 3.7.0
Closes: https://bugs.gentoo.org/895304 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/tmux-mem-cpu-load')
-rw-r--r--app-misc/tmux-mem-cpu-load/Manifest1
-rw-r--r--app-misc/tmux-mem-cpu-load/files/tmux-mem-cpu-load-3.7.0-gcc13.patch24
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild26
-rw-r--r--app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild4
4 files changed, 53 insertions, 2 deletions
diff --git a/app-misc/tmux-mem-cpu-load/Manifest b/app-misc/tmux-mem-cpu-load/Manifest
index 143ff2c45522..7323b0aa516f 100644
--- a/app-misc/tmux-mem-cpu-load/Manifest
+++ b/app-misc/tmux-mem-cpu-load/Manifest
@@ -1 +1,2 @@
DIST tmux-mem-cpu-load-3.5.1.tar.gz 23020 BLAKE2B 2bbe2441c0fd687fee4ed2f27b8cea0fdbb0596c36fe8c791be110b880abe5d8c28a14960a9836552cf49b4f92d32a127be9271954853c5310f1628791138f7a SHA512 e08a3ad088021d4f4a3fb671a15cc8468a833501202391a63f57d3b53ea65934dc32869c3b7bbe47bce7d8ff2c9d1d35a5823a70c80d1218392aac82ed96e68f
+DIST tmux-mem-cpu-load-3.7.0.tar.gz 23374 BLAKE2B 61dfd556b22afd37d7011c2f31e1c1ee2632921c590ac273e92baf18f018d09eaffc628490d8c2bca973fc73dba67f83dfd380792c70f7fac8335cc9c732d7c3 SHA512 0a87d91e2d7ea0b687b0610b913aa782813fc80cc689c6f42fa2e1537715b7b2307edbfabf231fc0e13fe5aeaca1c0ffa4500ce338b37365ba0ac7a8b69e7385
diff --git a/app-misc/tmux-mem-cpu-load/files/tmux-mem-cpu-load-3.7.0-gcc13.patch b/app-misc/tmux-mem-cpu-load/files/tmux-mem-cpu-load-3.7.0-gcc13.patch
new file mode 100644
index 000000000000..77e905aa8fb9
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/files/tmux-mem-cpu-load-3.7.0-gcc13.patch
@@ -0,0 +1,24 @@
+https://github.com/thewtex/tmux-mem-cpu-load/pull/95
+
+From 59cca005e4c6d2fe9f90574a99afe78dcb6d8539 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 18 Apr 2023 04:25:00 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/895304
+--- a/common/cpu.h
++++ b/common/cpu.h
+@@ -19,6 +19,7 @@
+ #ifndef CPU_H_
+ #define CPU_H_
+
++#include <cstdint>
+ #include <sys/types.h>
+
+ #if defined(__APPLE__) && defined(__MACH__)
+
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild
new file mode 100644
index 000000000000..72e6848796f4
--- /dev/null
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-3.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/thewtex/tmux-mem-cpu-load.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/thewtex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
+HOMEPAGE="https://github.com/thewtex/tmux-mem-cpu-load"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.7.0-gcc13.patch
+)
diff --git a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild
index e8fe363b9562..8cf26ebed9d5 100644
--- a/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild
+++ b/app-misc/tmux-mem-cpu-load/tmux-mem-cpu-load-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999* ]]; then
inherit git-r3
else
SRC_URI="https://github.com/thewtex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"