summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-04-18 15:19:35 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-04-18 15:19:35 -0700
commit2f740d1ace34c63e9f368fa0569335bbd2811a0e (patch)
tree9362994b8ed848663d449afbadcf4a4985c0d374 /app-misc/tmuxp
parentdev-util/ruff: add 0.4.0, drop 0.3.7 (diff)
downloadgentoo-2f740d1ace34c63e9f368fa0569335bbd2811a0e.tar.gz
gentoo-2f740d1ace34c63e9f368fa0569335bbd2811a0e.tar.bz2
gentoo-2f740d1ace34c63e9f368fa0569335bbd2811a0e.zip
app-misc/tmuxp: add 1.46.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp')
-rw-r--r--app-misc/tmuxp/Manifest1
-rw-r--r--app-misc/tmuxp/tmuxp-1.46.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/tmuxp/Manifest b/app-misc/tmuxp/Manifest
index 68dd06ad8fc2..44c4b6b6e069 100644
--- a/app-misc/tmuxp/Manifest
+++ b/app-misc/tmuxp/Manifest
@@ -5,3 +5,4 @@ DIST tmuxp-1.38.0.tar.gz 869977 BLAKE2B 6bbb44ceea34af68a7cac0acdf35ee19de74611c
DIST tmuxp-1.40.0.tar.gz 870034 BLAKE2B ab2e6c08ea328e622713e355ff30e9781f2487b9a762ebd7c36195cd8522eee9eab70d66736a1f687e6336f317fdd556d8ee45e9921bd9b1b501189b540e92bb SHA512 6e8564ed2b57122772f1c7b73425b49b6d521141b8e4a3ff6b65d3fb57e6952dfdbb90941242d6d5d8fff70bf7a4533e60ec3dc0abae39637366f035aa237984
DIST tmuxp-1.43.0.tar.gz 869217 BLAKE2B ebaa230723288a37334ee55c9b615610d66aacc5b01d6bf70576de38e9aa1ecc29a7d26299b55880e9ede403855304de080ddec6a16798a269d6bb8d4629498c SHA512 2dec0c941e919258fd884374fe89cf8e558483a50d53a4c6e3148f7639057aa365a959c062ea6929301dcd893b8a6794c002102f030d77fb904eeaa31ec30edd
DIST tmuxp-1.45.0.tar.gz 869918 BLAKE2B e0f402ec8add4119e3d49b774e0dca0879a54f2f7d3b492979d7e46652ae07bba005c0a5d4784049d8a6c91c83ebf0346aac959ef730f35c63b8fba12459f680 SHA512 426d58c24330f184205a3f6ecbfc0e6871b8372ed882847272a336283f5e02f3461da0e01b0c47c8800a757486fd15f22b02f7175bdd128d5a7aab11a25080b7
+DIST tmuxp-1.46.0.tar.gz 870062 BLAKE2B b8c450e186097584e4f67de6375acd898b02826ad2a7c758cf0a502c7b60c5dad7ae537df8bcc18310ec6c20cd52700d5d87d336e23de4a786c607eb57ffe5f3 SHA512 1e2fa9b20ade766c7bcbec5b3b430c118cfa27b00e808241d0daf6720351d35863000f22ff052bf0f9f38a63e21813814591312ab0c5af14488a6546af5440ed
diff --git a/app-misc/tmuxp/tmuxp-1.46.0.ebuild b/app-misc/tmuxp/tmuxp-1.46.0.ebuild
new file mode 100644
index 000000000000..b77d79f89706
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.46.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.36*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6.2.5[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.14.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]' 3.{9..10})
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -r -e 's:libtmux = "~[0-9.]+":libtmux = "~0.30":' \
+ -i pyproject.toml || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}