summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-mobilephone/pysms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-mobilephone/pysms')
-rw-r--r--app-mobilephone/pysms/Manifest1
-rw-r--r--app-mobilephone/pysms/metadata.xml11
-rw-r--r--app-mobilephone/pysms/pysms-0.9.4-r1.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/app-mobilephone/pysms/Manifest b/app-mobilephone/pysms/Manifest
new file mode 100644
index 000000000000..7fea9a6562cc
--- /dev/null
+++ b/app-mobilephone/pysms/Manifest
@@ -0,0 +1 @@
+DIST pysms-0.9.4.tar.gz 57843 SHA256 a32742f8fb58656f45f6b65b6c3d4191df8b5c47ba454c648fafd45a86040a34 SHA512 7f2a1279368b68ef17e16f346079aa5f3daf50c7ab43570425e9be8c5144e6c291390e4178fded52f7fcd16aeb2960993897036d09ee265f2717fe60d583e8d9 WHIRLPOOL 8d55a58031c659b720be791236ddc1e83f94111259b966e6be53fd7a501e09c802c220c9914d7f67303a76ce53611505a536ef9022b2f14cf7d0eaeff76dc552
diff --git a/app-mobilephone/pysms/metadata.xml b/app-mobilephone/pysms/metadata.xml
new file mode 100644
index 000000000000..b5fc49dd930a
--- /dev/null
+++ b/app-mobilephone/pysms/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Tool for sending text messages for various Swiss providers</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pysms</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-mobilephone/pysms/pysms-0.9.4-r1.ebuild b/app-mobilephone/pysms/pysms-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..b37caf87dbce
--- /dev/null
+++ b/app-mobilephone/pysms/pysms-0.9.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for sending text messages for various Swiss providers"
+HOMEPAGE="http://sourceforge.net/projects/pysms/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygtk[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ sed -e "s:0.9.1:0.9.4:" \
+ -e "s/Application;Network/Network/" \
+ -i data/pysms.desktop || die
+ rm -f MANIFEST.in
+
+ distutils-r1_python_prepare
+}