summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-06-03 19:35:34 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-06-03 19:35:34 +0200
commit1d3dda3d680b411bf38a965c6490bc45e58ff3d2 (patch)
tree8a1ef282cd2fc541cddd306b1b49841d4e6f498c /app-office
parentapp-crypt/certbot-nginx: fix variable ordering (diff)
downloadgentoo-1d3dda3d680b411bf38a965c6490bc45e58ff3d2.tar.gz
gentoo-1d3dda3d680b411bf38a965c6490bc45e58ff3d2.tar.bz2
gentoo-1d3dda3d680b411bf38a965c6490bc45e58ff3d2.zip
app-office/scribus: fixed one boost issue in 1.6.1-r1
Bug: https://bugs.gentoo.org/932492 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/scribus/files/scribus-1.6.1-boost-1.85.patch39
-rw-r--r--app-office/scribus/scribus-1.6.1-r1.ebuild1
2 files changed, 40 insertions, 0 deletions
diff --git a/app-office/scribus/files/scribus-1.6.1-boost-1.85.patch b/app-office/scribus/files/scribus-1.6.1-boost-1.85.patch
new file mode 100644
index 000000000000..9d5dc0868843
--- /dev/null
+++ b/app-office/scribus/files/scribus-1.6.1-boost-1.85.patch
@@ -0,0 +1,39 @@
+From 3e80b387a226f1abac2bcce6e4300467c189d264 Mon Sep 17 00:00:00 2001
+From: Jean Ghali <jghali@libertysurf.fr>
+Date: Sat, 1 Jun 2024 22:04:13 +0000
+Subject: [PATCH] #17229: scribus fails to compile with boost 1.85.0
+
+git-svn-id: svn://scribus.net/branches/Version16x/Scribus@26170 11d20701-8431-0410-a711-e3c959e3b870
+--- a/scribus/third_party/lib2geom/point.h
++++ b/scribus/third_party/lib2geom/point.h
+@@ -121,10 +121,14 @@ class Point {
+
+ Point &operator*=(Matrix const &m);
+
+- inline int operator == (const Point &in_pnt) {
++ inline bool operator==(const Point &in_pnt) const {
+ return ((_pt[X] == in_pnt[X]) && (_pt[Y] == in_pnt[Y]));
+ }
+
++ inline bool operator!=(const Point &in_pnt) const {
++ return ((_pt[X] != in_pnt[X]) || (_pt[Y] != in_pnt[Y]));
++ }
++
+ friend inline std::ostream &operator<< (std::ostream &out_file, const Geom::Point &in_pnt);
+ };
+
+@@ -144,14 +148,6 @@ inline Point operator^(Point const &a, Point const &b) {
+ return ret;
+ }
+
+-//IMPL: boost::EqualityComparableConcept
+-inline bool operator==(Point const &a, Point const &b) {
+- return (a[X] == b[X]) && (a[Y] == b[Y]);
+-}
+-inline bool operator!=(Point const &a, Point const &b) {
+- return (a[X] != b[X]) || (a[Y] != b[Y]);
+-}
+-
+ /** This is a lexicographical ordering for points. It is remarkably useful for sweepline algorithms*/
+ inline bool operator<=(Point const &a, Point const &b) {
+ return ( ( a[Y] < b[Y] ) ||
diff --git a/app-office/scribus/scribus-1.6.1-r1.ebuild b/app-office/scribus/scribus-1.6.1-r1.ebuild
index bf38de284c12..e112af815030 100644
--- a/app-office/scribus/scribus-1.6.1-r1.ebuild
+++ b/app-office/scribus/scribus-1.6.1-r1.ebuild
@@ -78,6 +78,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.7.0-fix-icon-version.patch
"${FILESDIR}"/${PN}-1.6.1-poppler-24.03.patch
"${FILESDIR}"/${PN}-1.6.1-poppler-24.05.patch
+ "${FILESDIR}"/${PN}-1.6.1-boost-1.85.patch
)
src_prepare() {