summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-06-02 14:46:23 -0400
committerSam James <sam@gentoo.org>2024-06-02 22:15:42 +0100
commit68cd2be55e38cdcbdfada4cfcf1270d26aab35fd (patch)
treedb6e23f9614e8449cd4041d36a228695cb8c656b /app-portage
parentapp-vim/jedi: enable py3.12 (diff)
downloadgentoo-68cd2be55e38cdcbdfada4cfcf1270d26aab35fd.tar.gz
gentoo-68cd2be55e38cdcbdfada4cfcf1270d26aab35fd.tar.bz2
gentoo-68cd2be55e38cdcbdfada4cfcf1270d26aab35fd.zip
app-portage/gentoolkit: remove pointless shebang sed of library files
The shebang of a file in site-packages doesn't matter, regardless of what it is. It is at best an editor hint. But it adds many lines to the portage output. Stop sed'ing these. No revbump. Changes result in different bytes but the changes themselves are totally inert. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.6.3-r1.ebuild1
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.6.5.ebuild1
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.6.6.ebuild1
-rw-r--r--app-portage/gentoolkit/gentoolkit-0.6.7.ebuild1
-rw-r--r--app-portage/gentoolkit/gentoolkit-9999.ebuild1
5 files changed, 0 insertions, 5 deletions
diff --git a/app-portage/gentoolkit/gentoolkit-0.6.3-r1.ebuild b/app-portage/gentoolkit/gentoolkit-0.6.3-r1.ebuild
index 36bae9f8dac2..12c98846bbf9 100644
--- a/app-portage/gentoolkit/gentoolkit-0.6.3-r1.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.6.3-r1.ebuild
@@ -95,7 +95,6 @@ my_src_install() {
)
meson_src_install
- python_fix_shebang "${pydirs[@]}"
python_optimize "${pydirs[@]}"
}
diff --git a/app-portage/gentoolkit/gentoolkit-0.6.5.ebuild b/app-portage/gentoolkit/gentoolkit-0.6.5.ebuild
index 06657eae3abe..10786b3e8d2e 100644
--- a/app-portage/gentoolkit/gentoolkit-0.6.5.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.6.5.ebuild
@@ -95,7 +95,6 @@ my_src_install() {
)
meson_src_install
- python_fix_shebang "${pydirs[@]}"
python_optimize "${pydirs[@]}"
}
diff --git a/app-portage/gentoolkit/gentoolkit-0.6.6.ebuild b/app-portage/gentoolkit/gentoolkit-0.6.6.ebuild
index 5eb3d884baf5..d00878e10f08 100644
--- a/app-portage/gentoolkit/gentoolkit-0.6.6.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.6.6.ebuild
@@ -101,7 +101,6 @@ my_src_install() {
)
meson_src_install
- python_fix_shebang "${pydirs[@]}"
python_optimize "${pydirs[@]}"
}
diff --git a/app-portage/gentoolkit/gentoolkit-0.6.7.ebuild b/app-portage/gentoolkit/gentoolkit-0.6.7.ebuild
index 5eb3d884baf5..d00878e10f08 100644
--- a/app-portage/gentoolkit/gentoolkit-0.6.7.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-0.6.7.ebuild
@@ -101,7 +101,6 @@ my_src_install() {
)
meson_src_install
- python_fix_shebang "${pydirs[@]}"
python_optimize "${pydirs[@]}"
}
diff --git a/app-portage/gentoolkit/gentoolkit-9999.ebuild b/app-portage/gentoolkit/gentoolkit-9999.ebuild
index 5eb3d884baf5..d00878e10f08 100644
--- a/app-portage/gentoolkit/gentoolkit-9999.ebuild
+++ b/app-portage/gentoolkit/gentoolkit-9999.ebuild
@@ -101,7 +101,6 @@ my_src_install() {
)
meson_src_install
- python_fix_shebang "${pydirs[@]}"
python_optimize "${pydirs[@]}"
}