summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /app-shells
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/atuin/atuin-18.3.0-r2.ebuild (renamed from app-shells/atuin/atuin-18.3.0-r1.ebuild)3
-rw-r--r--app-shells/mcfly/mcfly-0.5.13-r1.ebuild115
-rw-r--r--app-shells/mcfly/mcfly-0.5.13.ebuild115
-rw-r--r--app-shells/mcfly/mcfly-0.9.0-r1.ebuild (renamed from app-shells/mcfly/mcfly-0.9.0.ebuild)0
-rw-r--r--app-shells/nushell/nushell-0.95.0-r1.ebuild (renamed from app-shells/nushell/nushell-0.95.0.ebuild)0
-rw-r--r--app-shells/nushell/nushell-0.96.1-r1.ebuild (renamed from app-shells/nushell/nushell-0.96.1.ebuild)0
-rw-r--r--app-shells/nushell/nushell-0.98.0-r1.ebuild (renamed from app-shells/nushell/nushell-0.98.0.ebuild)2
-rw-r--r--app-shells/starship/starship-1.19.0-r1.ebuild (renamed from app-shells/starship/starship-1.19.0.ebuild)2
-rw-r--r--app-shells/starship/starship-1.20.1-r1.ebuild (renamed from app-shells/starship/starship-1.20.1.ebuild)2
-rw-r--r--app-shells/zoxide/zoxide-0.9.4-r1.ebuild (renamed from app-shells/zoxide/zoxide-0.9.4.ebuild)0
-rw-r--r--app-shells/zoxide/zoxide-0.9.6-r1.ebuild (renamed from app-shells/zoxide/zoxide-0.9.6.ebuild)0
11 files changed, 120 insertions, 119 deletions
diff --git a/app-shells/atuin/atuin-18.3.0-r1.ebuild b/app-shells/atuin/atuin-18.3.0-r2.ebuild
index 584ccab1160b..2aeb85eee95a 100644
--- a/app-shells/atuin/atuin-18.3.0-r1.ebuild
+++ b/app-shells/atuin/atuin-18.3.0-r2.ebuild
@@ -454,6 +454,8 @@ CRATES="
zeroize_derive@1.4.2
"
+RUST_MIN_VER="1.71.1"
+
inherit cargo greadme shell-completion systemd
DESCRIPTION="Shell history manager supporting encrypted synchronisation"
@@ -482,7 +484,6 @@ DEPEND="test? ( dev-db/postgresql )"
# protox with 9fa223eaaf0e ("chore(build): compile protobufs with protox (#2122)")
BDEPEND="
dev-libs/protobuf
- >=virtual/rust-1.71.0
"
QA_FLAGS_IGNORED="usr/bin/${PN}"
diff --git a/app-shells/mcfly/mcfly-0.5.13-r1.ebuild b/app-shells/mcfly/mcfly-0.5.13-r1.ebuild
new file mode 100644
index 000000000000..0f6affe490b3
--- /dev/null
+++ b/app-shells/mcfly/mcfly-0.5.13-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 2017-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+ aho-corasick@0.7.10
+ ansi_term@0.11.0
+ arrayref@0.3.6
+ arrayvec@0.5.1
+ atty@0.2.14
+ autocfg@1.0.0
+ base64@0.11.0
+ bitflags@1.2.1
+ blake2b_simd@0.5.10
+ bstr@0.2.12
+ byteorder@1.3.4
+ cc@1.0.52
+ cfg-if@0.1.10
+ chrono@0.4.19
+ clap@2.33.0
+ constant_time_eq@0.1.5
+ crossbeam-utils@0.7.2
+ csv@1.1.3
+ csv-core@0.1.10
+ dirs@2.0.2
+ dirs-sys@0.3.4
+ either@1.6.1
+ getrandom@0.1.14
+ hermit-abi@0.1.12
+ humantime@2.1.0
+ itertools@0.9.0
+ itoa@0.4.5
+ lazy_static@1.4.0
+ libc@0.2.69
+ libsqlite3-sys@0.10.0
+ linked-hash-map@0.5.3
+ lru-cache@0.1.2
+ memchr@2.3.3
+ num-integer@0.1.44
+ num-traits@0.2.14
+ numtoa@0.1.0
+ pkg-config@0.3.17
+ ppv-lite86@0.2.6
+ rand@0.7.3
+ rand_chacha@0.2.2
+ rand_core@0.5.1
+ rand_hc@0.2.0
+ redox_syscall@0.1.56
+ redox_termios@0.1.1
+ redox_users@0.3.4
+ regex@1.3.7
+ regex-automata@0.1.9
+ regex-syntax@0.6.17
+ relative-path@1.0.0
+ rusqlite@0.15.0
+ rust-argon2@0.7.0
+ ryu@1.0.4
+ serde@1.0.106
+ shellexpand@2.0.0
+ strsim@0.8.0
+ termion@1.5.5
+ textwrap@0.11.0
+ thread_local@1.0.1
+ time@0.1.43
+ unicode-segmentation@1.6.0
+ unicode-width@0.1.7
+ vcpkg@0.2.8
+ vec_map@0.8.2
+ wasi@0.9.0+wasi-snapshot-preview1
+ winapi@0.3.8
+ winapi-i686-pc-windows-gnu@0.4.0
+ winapi-x86_64-pc-windows-gnu@0.4.0
+"
+
+inherit cargo readme.gentoo-r1
+
+DESCRIPTION="Context-aware bash history search replacement (ctrl-r)"
+HOMEPAGE="https://github.com/cantino/mcfly"
+SRC_URI="https://github.com/cantino/mcfly/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}"
+
+LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 CC0-1.0 MIT Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+
+QA_FLAGS_IGNORED="usr/bin/mcfly"
+
+src_install() {
+ cargo_src_install
+
+ insinto /usr/share/${PN}
+ doins ${PN}.{bash,fish,zsh}
+
+ # create README.gentoo
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS=\
+"To start using ${PN}, add the following to your shell:
+
+~/.bashrc
+eval \"\$(mcfly init bash)\"
+
+~/.config/fish/config.fish
+mcfly init fish | source
+
+~/.zsh
+eval \"\$(mcfly init zsh)\""
+ readme.gentoo_create_doc
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-shells/mcfly/mcfly-0.5.13.ebuild b/app-shells/mcfly/mcfly-0.5.13.ebuild
deleted file mode 100644
index 888504821bc2..000000000000
--- a/app-shells/mcfly/mcfly-0.5.13.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 2017-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CRATES="
- aho-corasick-0.7.10
- ansi_term-0.11.0
- arrayref-0.3.6
- arrayvec-0.5.1
- atty-0.2.14
- autocfg-1.0.0
- base64-0.11.0
- bitflags-1.2.1
- blake2b_simd-0.5.10
- bstr-0.2.12
- byteorder-1.3.4
- cc-1.0.52
- cfg-if-0.1.10
- chrono-0.4.19
- clap-2.33.0
- constant_time_eq-0.1.5
- crossbeam-utils-0.7.2
- csv-1.1.3
- csv-core-0.1.10
- dirs-2.0.2
- dirs-sys-0.3.4
- either-1.6.1
- getrandom-0.1.14
- hermit-abi-0.1.12
- humantime-2.1.0
- itertools-0.9.0
- itoa-0.4.5
- lazy_static-1.4.0
- libc-0.2.69
- libsqlite3-sys-0.10.0
- linked-hash-map-0.5.3
- lru-cache-0.1.2
- memchr-2.3.3
- num-integer-0.1.44
- num-traits-0.2.14
- numtoa-0.1.0
- pkg-config-0.3.17
- ppv-lite86-0.2.6
- rand-0.7.3
- rand_chacha-0.2.2
- rand_core-0.5.1
- rand_hc-0.2.0
- redox_syscall-0.1.56
- redox_termios-0.1.1
- redox_users-0.3.4
- regex-1.3.7
- regex-automata-0.1.9
- regex-syntax-0.6.17
- relative-path-1.0.0
- rusqlite-0.15.0
- rust-argon2-0.7.0
- ryu-1.0.4
- serde-1.0.106
- shellexpand-2.0.0
- strsim-0.8.0
- termion-1.5.5
- textwrap-0.11.0
- thread_local-1.0.1
- time-0.1.43
- unicode-segmentation-1.6.0
- unicode-width-0.1.7
- vcpkg-0.2.8
- vec_map-0.8.2
- wasi-0.9.0+wasi-snapshot-preview1
- winapi-0.3.8
- winapi-i686-pc-windows-gnu-0.4.0
- winapi-x86_64-pc-windows-gnu-0.4.0
-"
-
-inherit cargo readme.gentoo-r1
-
-DESCRIPTION="Context-aware bash history search replacement (ctrl-r)"
-HOMEPAGE="https://github.com/cantino/mcfly"
-SRC_URI="https://github.com/cantino/mcfly/archive/v${PV}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris)"
-
-LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD BSD-2 CC0-1.0 MIT Unlicense"
-SLOT="0"
-KEYWORDS="~amd64"
-
-QA_FLAGS_IGNORED="usr/bin/mcfly"
-
-src_install() {
- cargo_src_install
-
- insinto /usr/share/${PN}
- doins ${PN}.{bash,fish,zsh}
-
- # create README.gentoo
- local DISABLE_AUTOFORMATTING="yes"
- local DOC_CONTENTS=\
-"To start using ${PN}, add the following to your shell:
-
-~/.bashrc
-eval \"\$(mcfly init bash)\"
-
-~/.config/fish/config.fish
-mcfly init fish | source
-
-~/.zsh
-eval \"\$(mcfly init zsh)\""
- readme.gentoo_create_doc
-
- einstalldocs
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
diff --git a/app-shells/mcfly/mcfly-0.9.0.ebuild b/app-shells/mcfly/mcfly-0.9.0-r1.ebuild
index 2c4a7577b00a..2c4a7577b00a 100644
--- a/app-shells/mcfly/mcfly-0.9.0.ebuild
+++ b/app-shells/mcfly/mcfly-0.9.0-r1.ebuild
diff --git a/app-shells/nushell/nushell-0.95.0.ebuild b/app-shells/nushell/nushell-0.95.0-r1.ebuild
index 26e04a4ee1e0..26e04a4ee1e0 100644
--- a/app-shells/nushell/nushell-0.95.0.ebuild
+++ b/app-shells/nushell/nushell-0.95.0-r1.ebuild
diff --git a/app-shells/nushell/nushell-0.96.1.ebuild b/app-shells/nushell/nushell-0.96.1-r1.ebuild
index 36fc5ed12705..36fc5ed12705 100644
--- a/app-shells/nushell/nushell-0.96.1.ebuild
+++ b/app-shells/nushell/nushell-0.96.1-r1.ebuild
diff --git a/app-shells/nushell/nushell-0.98.0.ebuild b/app-shells/nushell/nushell-0.98.0-r1.ebuild
index ad8fb2112036..9d5bc205942e 100644
--- a/app-shells/nushell/nushell-0.98.0.ebuild
+++ b/app-shells/nushell/nushell-0.98.0-r1.ebuild
@@ -698,6 +698,7 @@ CRATES="
zstd@0.13.2
"
+RUST_MIN_VER="1.79.0"
inherit cargo
DESCRIPTION="A new type of shell, written in Rust"
@@ -732,7 +733,6 @@ DEPEND="
"
RDEPEND="${DEPEND}"
BDEPEND="
- >=virtual/rust-1.79.0
virtual/pkgconfig
"
diff --git a/app-shells/starship/starship-1.19.0.ebuild b/app-shells/starship/starship-1.19.0-r1.ebuild
index c44e5bb3dec5..ccaa9e9dcd64 100644
--- a/app-shells/starship/starship-1.19.0.ebuild
+++ b/app-shells/starship/starship-1.19.0-r1.ebuild
@@ -5,6 +5,7 @@ EAPI=8
CRATES=""
+RUST_MIN_VER="1.74.1"
inherit cargo
DESCRIPTION="The minimal, blazing-fast, and infinitely customizable prompt for any shell"
@@ -26,7 +27,6 @@ KEYWORDS="amd64 arm64"
BDEPEND="
dev-build/cmake
- >=virtual/rust-1.74.1
"
QA_FLAGS_IGNORED="usr/bin/starship"
diff --git a/app-shells/starship/starship-1.20.1.ebuild b/app-shells/starship/starship-1.20.1-r1.ebuild
index a6607e763860..6080429d8bc4 100644
--- a/app-shells/starship/starship-1.20.1.ebuild
+++ b/app-shells/starship/starship-1.20.1-r1.ebuild
@@ -395,6 +395,7 @@ CRATES="
zvariant_utils@2.1.0
"
+RUST_MIN_VER="1.74.1"
inherit cargo
DESCRIPTION="The minimal, blazing-fast, and infinitely customizable prompt for any shell"
@@ -414,7 +415,6 @@ KEYWORDS="amd64 arm64"
BDEPEND="
dev-build/cmake
- >=virtual/rust-1.74.1
"
QA_FLAGS_IGNORED="usr/bin/starship"
diff --git a/app-shells/zoxide/zoxide-0.9.4.ebuild b/app-shells/zoxide/zoxide-0.9.4-r1.ebuild
index 000e4b303a2d..000e4b303a2d 100644
--- a/app-shells/zoxide/zoxide-0.9.4.ebuild
+++ b/app-shells/zoxide/zoxide-0.9.4-r1.ebuild
diff --git a/app-shells/zoxide/zoxide-0.9.6.ebuild b/app-shells/zoxide/zoxide-0.9.6-r1.ebuild
index ebabae35a6f2..ebabae35a6f2 100644
--- a/app-shells/zoxide/zoxide-0.9.6.ebuild
+++ b/app-shells/zoxide/zoxide-0.9.6-r1.ebuild